Symptom
You are not able to add an already existing Tax Exemption Certificates in a Corporate Account, system shows the message: Instance with the same key already exists.
Reproducing the Issue
- Go to Account Management work center.
- Go to Accounts view.
- Search for the account.
- Click on Edit > Financial Data button.
- Go to Tax Exemption Tab.
- You attempt to add a new row with an existing Tax Exemption Certificate ID and system throws the error:
Instance with the same key already exists.
Cause
The system won't allow to create another certificate with the same Tax Exemption Certificate ID. It is also is not possible to delete a void certificate from the system. This is the expected behavior.
Resolution
It is not possible to create another certificate with same Tax Exemption Certificate ID. Neither is it feasible to perform this from the backend of the system.
An alternative would be the field External ID in General tab which is enabled when you create a new certificate. This field is editable only when the certificate is in Preparation status (before making it active).
Keywords
KBA , tax exemption certificate id , tax exemption certificate id , instance with the same key already exist , SRD-CRM-ACC , Account Management , How To