Symptom
Customer installed a new Windows 2008 R2 Server. All Printers are local Printer (tcp/IP port) and are transferred with the Export/Import Printer tool from another Windows 2008 R2 Server.
NOTE: This Printer Import/Export tool belongs to Microsoft and could not be found in current downloads from Microsoft to confirm the issue.
- On the source Windows 2008 R2 Server it takes a few seconds for CR2008 to open the print Dialog.
- On the new Server CR2008 and CR2013 takes 3-5 minutes to Display the print Dialog box.
- Doing the same in WordPad works fine and fast.
Environment
Crystal Reports 2008
Crystal Reports 2013
Windows 2008 R2 Server ( configured as a Printer Spooler )
Cause
The import tool from Microsoft may not set all of the options as the source printers are configured.
One of those settings is called "Render print jobs on client computers" located on the Sharing tab of the Printer properties
Also, there appears to be a potential issue with the Client Side printing, see this MS Kbase article for more info:
http://msdn.microsoft.com/en-us/library/windows/hardware/ff556443(v=vs.85).aspx
Also note: CR Designer has always required the printers to be installed locally so the layout can be formatted according to the defined printer setting saved with the report.
Resolution
If the printer supports this feature "Render print jobs on client computers" located on the Sharing tab of the Printer properties, check the option ON.
Keywords
KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Problem