SAP Knowledge Base Article - Public

2025073 - Unable to Create Employees Since New Button is Disabled

Symptom

You want to create new Employees in the C4C system, but found it impossible to do so as the New button is disabled.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Administrator work center.
  2. Access the General Settings work center view.
  3. Click the Employees link.
  4. In the new screen, the New button is disabled (grayed out).

Cause

The cause for the behavior is that your tenant is scoped so that employees are replicated from an external application. This can be verified as follows:

  1. Go to Business Configuration work center.
  2. Access the Implementations Projects view.
  3. Select the First Implementation project and click the Edit Project Scope button
  4. Go to step 4 - Review Questions.
  5. Expand Communication and Information Exchange.
  6. Next, expand Integration with External Applications and Solutions.
  7. Select Integration of Master Data.
  8. Here, the question "Do you want to replicate employee data from external application or solution of your cloud solution?" is checked.

Resolution

In tenants where integration is scoped, creating an employee directly on C4C side is not allowed, as it can generate inconsistencies between the data in C4C and the data in the external system integrated with it. Hence, please create the new employee in the external system, then replicate it to C4C.

The same behavior also applies to replication of different business partners as well (customers, contacts, etc.),

Keywords

Create, New, Employee, Account, Contact, Business Partner, Disabled, Replication, Integration , KBA , LOD-CRM-EMP , Employee , How To

Product

SAP Hybris Cloud for Customer add-ins 1708 ; SAP Hybris Cloud for Customer add-ins 1711