Symptom
After clicking the print button on the Toolbar in the report viewer, it takes a long time for the print dialogue box to appear.
The time lag from clicking the Print Icon to seeing the Windows Print Dialog is related to how many pages the report has (it appears the printable image is rendered before the dialog is presented). 600 pages results in a 30-second delay'; 1200 pages around 1 minute. It looks like RAS is able to generate about 20 pages per second as it processes the print request.
Environment
- Crystal Reports Server Embedded ( OEM )
- Crystal Reports for Visual Studio
Reproducing the Issue
- Create a simple WEB application and in the Form where the CR WEB Viewer is located set the Default Print Mode to PDF, default is ActiveX.
- Preview a report with saved data
- Click the print button
- Note the time it takes for the print Dialog to pop up, it is directly related to how long it takes to process the report.
- Once completed then the PDF Print dialog box appears
Cause
This is By design. When using PDF printer, report will be exported to PDF in backend first, and then it will be sent to the Adobe PDF printer to pop up the print dialog..
In BOE/BI, it will be the same when first viewing the report. The second time viewing report in BOE/BI, Cache Server will be involved, which will make PDF print dialog appear soon.
Because unmanaged RAS ( CRSE and InProc RAS ) does not have a Cache Server the report will need to process each time and therefore the print dialog will not popup until the report is finished exporting to pdf in the backend.
Note: In BOE the Page Server, when clicking printer button the first time, the behavior is the same as unmanaged RAS. The second time, print dialog will appear sooner.
The time will be long during printing progress, because cache will not cover all the report content if report size is large..
Comparing with ActiveX print, the difference is where the report running time is included:
- PDF - Process the report before print dialog prompt
- ActiveX- Process the report after the Print Dialog prompt
Resolution
Set the Print Mode to ActiveX in the Viewer properties
Keywords
KBA , BI-RA-CR-VW , Viewers , Problem