SAP Knowledge Base Article - Public

2043530 - Error HDB 10005: The engine failed to start before timeout. Restart the application. Lumira Desktop

Symptom

The following error message is displayed when opening up a document via double click - “The engine failed to start before timeout. Restart the application. (HDB 10005)”.

Environment

SAP Lumira Desktop - all versions

Reproducing the Issue

Open a complex LUMS document via double click.

Cause

There are two possible causes of this symptom:
1) Default engine start timeout has been exceeded
2) Local temporary database is corrupt.

Diagnose the problem via tracing
1) Edit C:\Program Files\SAP Lumira\Desktop\BO_trace.ini
2) Update the 'importance' field value to 'xs' in so it looks like:
importance = xs;
3) Restart SAP Lumira, attempt to open a document and check the logs

The log file can be found in:

<User home directory>\AppData\Local\Temp\sapvi\logs

or

%temp%\sapvi\logs

 If the log file contains an SQL exception then the local temporary database is corrupt else the default engine start timeout has been exceeded

 

Resolution

Exceeded the default engine start timeout

To override the default engine start timeout of 30 seconds add the following parameter to C:\Program Files\SAP Lumira\Desktop\SAPLumira.ini:

-Dhilo.iq.start.timeout=<timeout value in milliseconds>

Local temporary database is corrupt 

If the local temporary database is corrupt you need to delete the temporary working directory:

<User home directory>\AppData\Local\SAP\Lumira\DataBase

Keywords

  • Lumira Desktop
  • LUMS
  • Load Error
  • Opening Error
, KBA , BI-LUM-DIS , Lumira Desktop/Discovery , Problem

Product

SAP Lumira, desktop edition 1.0