Symptom
When trying to Import Customers or Suppliers using Mass Data Maintenance, system throws an error message, or does not perform the change. Examples:
- Example 1: Error: Update not possible; specified data for CUSTOMER-SALES_ARRANGEMENT with key DISTRIBUTION_CHANNEL_CODE-CONTENT = `01` AND SALES_ORGANISATION_UUID-CONTENT =`ABC` does not exist
- Example 2: Error: Update not possible; specified data for SUPPLIER-PAYMENT_DATA with key COMPANY_ID = `XYZ` does not exist.
- Example 3: The Validation is successful and says: No Invalid Data Found. But the import of some records fails with Service Call error
(Note: ABC represents a Sales Organisation and XYZ represents a Company ID)
Environment
- SAP Business ByDesign
- SAP Cloud for Customer
Reproducing the Issue
- Go to Mass Data Maintenance work center
- Select Import Customers or Suppliers and perform the action
Cause
The cause for the issue is that you are using Mass Data Maintenance to add new data for the Sales Data (example 1+3) or Payment Data (example 2+3) sheet, which is not correct.
The Mass Data Maintenance is only used to modify the records. It will not create new entries. In order to create new entries in other sheets of the migration template for the already existing accounts, the migration tool needs to be used.
Resolution
- Use the migration tool to create a file for the failed records of the Sales Data respectively Payment Data sheet, using method Migration Mode as Enhance already existing records, and proceed with the normal migration process.
- Note: Mass Data Maintenance can only be used to modify existing data.
Keywords
fails, not possible, unable, try, attempt, does not work , KBA , SRD-CC-MIG-DMC , Migration: Tool , AP-BP-SUP , BusinessByDesign: Supplier , How To