Symptom
Using the work center Payables you created a Payment Run which generated Payment Proposals. Once opening these payment proposals on the Automatic Payments view you noticed the Payee Bank Information is not the one you are expecting to see. The system is ignoring the main bank concept.
Environment
SAP Business ByDesign
Reproducing the Issue
In order to see the Payment Run ID you can use the underneath steps:
- Go to Payables work center
- Select the Periodic Tasks view
- And click on Payment Runs
- Search your ID reference and Go
- Under the Execution Details information
- Show the All Logs option
- Click on the application log number
- And select the Results tab
- Find for your supplier name and for the payment proposal ID
Steps to see the Payee Bank Information of the payment proposal created through the Payment Run:
- Go to Payables work center
- Select Automatic Payments view
- Show All Payment Proposals option
- Search for the Payment Proposal ID and open it
- On the Payee Bank Information is possible see the Bank Account Number ABC.
You are not expecting to see the Bank Account Number ABC on this payment proposal, but the Bank Account Number 123 as it is the main account for this supplier.
Here the steps to see the supplier master data bank account details:
- Go to Supplier Base work center
- Select Suppliers view
- Search for the supplier name or ID and Go
- Select the supplier and click on Edit Financial Data
- Select the Bank Data tab
- TheBank Account Number ABC is maintained on the Supplier Master Data in the first line.
- The Bank Account Number 123 is maintained on the Supplier Master Data in the second line.
Cause
System is picking for the Payee Bank Information the account which is maintained in the first line. If the main bank account is maintained in the second line system will choose the bank maintained in the first line ignoring the Main bank concept.
Resolution
Development team confirmed it is not always the case that the first bank account is picked in the proposal and currently there is no logic on the code perspective to pick it in a certain manner for customers. This issue is already known to development.
The only workaround available is to have only one account for the Supplier.
See Also
Incident 3100816826 is the same scenario for Employee Payment Run.
Keywords
Payee, Bank, Payment Run ID, , KBA , LOD-CRM , Cloud for Customer , How To