Symptom
SAP Lumira gives Error: Dataset cannot be published to SAP Lumira Server; publishing to SAP HANA layer failed. Reason: '<Not Available>'. (HDB 11009)
NOTE: SAP Lumira, server version for SAP HANA and SAP Lumira Cloud are being retired and will no longer receive new feature investments.
For more information please refer to SAP Knowledge Base Article:
Environment
- SAP HANA
- SAP Lumira
- SAP Lumira Server
Reproducing the Issue
- Create or open a document in SAP Lumira
- Publish a Dataset or Story to SAP Lumira Server
- Notice the error
Cause
SAP Lumira Server configuration is missing due to the inability to complete the following sections in "SAP Lumira Server Installation Guide"
- 2.4 To add the Configuration tile to SAP Fiori
- 2.5 To configure SAP Lumira Server
Resolution
For the Self-service Analytics feature daemon.ini->scriptserver->instances is set to 0 and it needs to be 1
- Connect with HANA Studio
- Right-click on the system and choose Configuration and Monitoring -> Open Administration
- Configuration tab
- Expand daemon.ini
- Expand scriptserver
- Enter 1 in the System value for instances
For the Discover feature a role and a setting are missing
- Connect with HANA Studio
- Add role “sap.bi.discover::BI_DISCOVER_SCHEDULER_PRIV” to the technical user used for SAP Lumira Server
- Right-click on the System and choose Configuration and Monitoring -> Open Administration
- Configuration tab
- Expand xsengine.ini
- Add scheduler
- Under scheduler add enabled
- Enter true in the System value for enabled
It is highly recommended to raise an case with the Fiori Support Team at component CA-FE-FLP to get Fiori working correctly on the system.
Keywords
- Upgrade
- HDB11009
- share
- UI5