Symptom
- How do we make all the fields on our Goal Plan or Development Plan show up in reports?
- Currently only some of the fields on Goal/Development plans are reportable by default
- An entire goal is not showing up in a report although it's seen on the goal plan
- A Goal Plan custom field is not visible in the reports
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors Goal Management
- SAP SuccessFactors Career Develoment Planning
Reproducing the Issue
- Go to the Report Center
- Create a new Report
- Try to report on Goal data or Development Goal data, e.g.; Status, Name, Description, Learning activitity data, etc.
- Some fields do not show in the Ad Hoc reports
Cause
- The fields have not been made reportable.
- Not all fields (standard and custom) are reportable by default
Resolution
This solution covers 2 scenarios:
-
Where a new field was not reportable when the goal plan was launched
- Goal plans typically do not have all fields set as reportable by default.
- Fields not set as reportable will not be transferring data to reporting tables and therefore when running reports you will find nothing in this field is showing in reports.
- If there are multiple fields on your goal plan/ development plan that do not currently show in reports, you will need to a paid partner engagement.
- You can request your goal plans be configured to add a "reportable" attribute to the field-definition elements for up to twenty fields you wish to report on.
- At most twenty fields across an entire instance may be reportable (including CDP etc.) The twenty fields are specified as Field1, field2 and field3...
- If a company has more than one objective template, all of the reportable="field1" fields must have the same id and be of the same type (text, date, enum, etc) across all objective plans.
- Likewise for all of the reportable="field2" and reportable="field3" fields across all objective plans.
- Once a field is made reportable, only new data going forward will show in the Objective list report.
- The configuration change will not apply to existing data.
- To push existing data to reports you will also need to request we run the "Goal Sync Tool" described below.
Note: Current functionality is deleted custom fields do not retain data when viewed in ad hoc reporting. If you deleted the field then it won't be reportable.
Implementation Request
- Depending on the scope and effort, the above actions may be out-of-scope for basic free support.
- If you have just 1 goal plan, and need to make just 1 field reportable, that would be within scope for the regular CCOR (Change Request) process.
- However if you have multiple goal plans, and multiple fields to be changed, this will require a paid engagement via PS/Partners.
Example Configuration:
<field-definition id="bizx-status-comments" type="text" required="false" detail="false" viewdefault="on" showlabel="true" field-show-coaching-advisor="false" cascade-update="push-down" reportable="field1">
Additional Information for Partners, PS & Support:
- Whoever is making the change needs to evaluate ALL the customers goal plans and determine the scope of work to make sure any change worked as needed, while not impacting any existing plan negatively.
- If the client already has fields set as reportable, then you must keep all reportable fields in sync across all goal plans, this includes goal and CDP plans!
- That is if weight: reportable=field2 on 2006 & 2007 plans then it needs to be same on the 2008 plan; you can't use =field1 on one plan and =field2 on another. You can't have date = reportable="field1" on a goal plan and name = reportable="field1" on a CDP plan for example. field1 would need to be consistent across all goal plan types. (Max of 20 reportable fields are supported)
- Make sure the Reportable Goal Field that has been made reportable is checked otherwise it will not appear on the Adhoc Report
Note: each field you make reportable must be unique. So you cannot use the same reportable field definition for different fields.
Example: you cannot use reportable="field1" for a status field, if it already being used for a description field. It will need its own reportable ID.
Goal Sync Tool
- When a field has existing data and you make it reportable, then you will also need to run the Goal Sync Tool to update the reporting tables.
- Go to Provisioning > Company Settings > Sync objective data to ad hoc report
- This will cause ALL goals to update and push data to reporting tables. All goals will have an audit entry showing they have been updated as of the date running the tool, and users will see alerts if you have those enabled.
- Nothing in the goal has changed, and the sync tool will not change anyones goal except for the last updated date.
- Partners can request access to Company Settings via the regular provisioning process so that you can perform these actions for the customer.
-
When an entire goal doesn't show in reports although it's visible in goal plan
- If your scenario is the goal is not in reports, and you are running a PM ad hoc report (Not a goal report) then the issue is possibly that you are adding the goal data via imports and your users never had a need to open their PM forms.
- For the system auto-sync to work typically users need to open their PM form, which is the point of time the system checks the goal plan to check for new goals.
- If users never had to open their PM forms, then the goal data is only on the goal plan, and not in the PM form, which is why the goal will not show in reports.
- There are a few ways to address this:
- Go into Admin Tools > Manage Templates > Select your template > Click the Open&Save option to manually trigger a goal sync to PM forms.
Or
- Have support run the Goal Sync Tool one time for you as decribed above (This is executed in provisioning (support access only). Screenshot below).
Or
- Have support enable the PM-GM Sync Up feature in your company settings which should eliminate this problem going forward.
Note on reporting on custom enum fields:
- If you have a custom field with enum values, and make it reportable, you must ensure that the field ID and enum values remain the same if you create a new development plan.
- Otherwise, if you change the values the system will not be able to display the new values in Ad Hoc reports.
- If you change enum values for a custom field, you must give that field a new ID and a new reportable tag.
Note to partners: The reportable field may take up to 30 minutes before it is visible in Ad Hoc
See Also
Keywords
SF, success factors, PMGM, GM, CDP, adhoc, rpt, custom field, report, reportable, field, Development, Goal, SuccessFactors , KBA , LOD-SF-GM-REP , Reporting and Data Imports Exports , LOD-SF-CDP-REP , Analytics & Reporting , How To