Symptom
Reports run by an Admin are getting stuck in "Waiting in Queue" status and are never generated.
Environment
SAP SuccessFactors Learning
Cause
The following permissions are not added to the Admin role, both permissions can be found under "System Administration":
- Edit All Background Job
- View All Background Job
Resolution
Add both permissions to the Admin role. If they are not added to the role, having the permissions to run the report, they will remain stuck in the queue.
To add mentioned workflows, you can follow the steps below:
- Go to System Administration > Security > Role Management
- Find the desired Role and Edit it
- Go to Permissions
- Click in "add one or more from list"
- Expand "System Administration"
- Find both roles (Edit All Background Job and View All Background Job) and check the "Add" checkbox
- Click in the "Add" button
If the admin already has the Edit and View All background job workflows, but the reports are still getting stuck or if reports from all admins are getting stuck, please create an case. There could be issues with the reporting nodes that the SuccessFactors Operations team needs to be involved.
Keywords
Stuck in Queue, Not Generated, Can't Run Report, cannot, able, role, permission, admin, reporting , KBA , LOD-SF-LMS-REP , Reporting Data , LOD-SF-LMS , Learning Management System , LOD-SF-LMS-BCJ , Assign (bulk), Add/ Delete Sub/ Cur, Revise, Import , Problem