SAP Knowledge Base Article - Public

2076009 - Performance Form Won't Open, Route, Looks Cut Off, or Has Formatting Issues

Symptom

Forms have been launched to many users and most forms are ok, but a few user forms are showing an error or are not working properly. Common issues include:

  • Users are getting an error: "An application error occurred. Please try again later, or notify support if the issue keeps occurring"
  • When routing a form, the user is kicked out to the home page
  • A form only partially loads and is cut off at some random spot
  • Forms look blank for some users while the same forms are correct for others
  • Users see page formatting issues with tables broken or nested incorrectly
  • Users see goal content showing up in the wrong place
  • A form works in one step but not in others
  • Various JavaScript errors are displayed (a yellow alert triangle is in the bottom left of browser)
  • Text fields show a higher character count than expected
  • Text in comment box looks cut off
  • A form routed to the next step cannot be opened and the page hangs

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP SuccessFactors Performance Management
  • SAP SuccessFactors 360 Multi-Rater 

Cause

  • A user cut/copied text from Microsoft Word (MS Word) into the goal plan or performance form: 
    • MS Word is an HTML-based program. Text copied from MS Word has HTML even though the code isn't visible, and is pasted as a random block of HTML into the form XML. Since it's displayed in a web browser that can only work with properly formatted HTML code, the partial/unsupported code breaks the form. While SuccessFactors has built-in capabilities to handle HTML code, it cannot handle every possible scenario. Errors will not occur every time someone pastes content into their forms, but there will be times when this will break the form.
    • SAP SuccessFactors does not recommend adding HTML, MS Word HTML, JavaScript, or special characters into comment boxes, competencies, or any XML template (Performance Management, 360 Multi-Rater, Career Development Planning, Goal Management). For more information on using HTML in the SuccessFactors application please see 2089419 - System: Using HTML or custom code within the SuccessFactors Application 
  • A user cut/copied text from an application or website and pasted it into the goal plan or performance form
  • A goal with bad data (HTML, Bullets) was cascaded to users
  • A competency with bad data (HTML, Bullets) was cascaded to users
  • A required field is hidden to the user at a specific step
  • The en-US locale is missing standard elements in the data model
  • Third-party software (anti-virus or security software) is blocking the content of the forms

Resolution

Below is a list of tests to help determine and remedy the cause of the issue:

Did the form ever work for anyone?

If the form has just been created and is being tested, or the form was not properly tested prior to launch and now users have broken live forms, it may be due to a misconfiguration.

  • Try replicating the issue using last year's form (the last known working version). Launch a form for one affected user and see if the same error appears.
  • If the error is not present in the old form for this user, and is only in the new form, then it is likely a misconfiguration of the new template. Some common configuration mistakes are:
    • It references competency ID's that existed in test but have a different ID in production.
    • There are more serious XML or HTML issues. Remove any HTML or formatted text added to the template. (typically in the instructional text areas)
    • Goals for the current year have bad data (HTML, Bullets) in them.
    • Competencies for the current year have special formatting or links added to them.
  • If the error appears when launching the last known good version of the form, the template may have some older code that is no longer passing validation and needs to be updated. 

Is only one user (or just a few) getting this error?

  • If Yes, it likely means the user copy/pasted bad HTML or text into the performance form comments and/or goal plan.
  • Launch a new copy of the form to see if there are any errors:
    • If the same error is not seen in a new form, this indicates the user has added bad data causing corruption. The user can use the new form and only paste plain text into the comment boxes.
    • If the error appears right away in a new form: it's possible the bad data is pulling into the form from the goal plan or competencies during launch.
    • It is recommended to enable the feature "The rich text editor cleans up text pasted from Microsoft Wordwhen the Rich Text Editor is enabled. This is enabled in Admin Center > Performance Management Feature Settings. This feature works with performance forms and will eliminate most of the issues introduced by pasting bad data into text fields.
  • Check the user's goal plan - remove goal data with special characters or with text copy/pasted from another application
    • Note: If the goal was cascaded to many users, all users may be seeing the same form error.
  • Does this user have a unique competency? Check competencies and make sure there is no HTML, links, or other special formatting (such as bullet points etc)
    • If there is bad data in the competency, the competency library will need to be updated. (other users with the same competency may also receive errors)
    • Relaunch the form once all corrections have been made to confirm if the error message is still present

Is this affecting many/all users?

  • Closely review forms paying close attention to the data being pulled into the form.
  • Do all users have something in common such as getting the same goal or competency?
  • Check goal data - look for HTML, bullets, or text added from other applications. If goals containing bad data have been cascaded to all users, the bad goal data will need to be removed. Once removed, check the performance forms to confirm the error is resolved.
  • Check the competency library and ensure there is no special formatting, bullets, or HTML that could corrupt the forms they appear on. If there is bad data in the competency, the competency library will need to be updated.
  • Relaunch the form once all corrections have been made to confirm if the error message is still present

Sanitizing content pasted into forms:

It's recommended to enable the following settings:

  • Sanitize all rich text inputs via Admin Tools > Company Settings > Company System & Logo Settings
  • The rich text editor cleans up text pasted from Microsoft Word (when the Rich Text Editor is enabled) via Admin Center > Performance Management Feature Settings.

While SuccessFactors has built-in capabilities to handle unsupported code, it cannot account for every possible scenario. While errors will not occur every time content is pasted into a form with the above options on, there will be times when undetected code causes issues. When this happens, users can "sanitize" text by trying the following steps:

  1. Copy the content as it was originally copied (usually from Word, Excel, a webpage or some other program)
  2. Paste the content into Notepad. Notepad is not an HTML-based editor, like MS Word or Excel, and will 'sanitize' this by stripping out all hidden HTML and converting it to plain text
  3. From notepad, reselect and copy the text
  4. Paste this plain text into a comment field of the performance form or goal plan > Save
  5. Reopen the form
  6. If the issue is still present, relaunch the form.

How to Identify if a User Pasted Text From a Word Document

Customers can use ad hoc reporting to pull in comment fields for a performance form. The comment fields will show unsupported HTML highlighted below:

For a full list of supported HTML, review Implementing and Managing Performance Management - Supported HTML for Performance Management Forms.

Any users who added unsupported HTML can have the form routed back to them to correct the text.

Misconfiguration of Required Fields

  • Review field permissions to see if there's a conflict. (For example a required field is hidden from the user in the current step.)

Example:

01.jpg

Here we see the section comments are a required field for all people at all steps. If there are hidden section comments at any step, a conflict is caused as they are required.

<required-fields>
<role-name>*</role-name>
<field refid="section-comments" min-value="-1.0" max-value="-1.0"/>
<route-step stepid="*"/>
<send-action sendid="next_step"/>
</required-fields>

The permissions need to change so that it's only required at specific steps and where the required roles can access the field.

3rd Party Security Software

  • Aggressive URL scanning (URL filtering) by 3rd party security software can interfere with the display and operation of SuccessFactors pages. Norton, McAfee, Kaspersky, and other security software scan SuccessFactors URLs and pages for JavaScript applets, malware, malicious code, and actively strip out pieces of HTML to sanitize the webpage.
  • SuccessFactors uses JavaScript and applets. If these are not allowed to run, pages can fail to load or URLs, buttons, and other navigational tools can fail. Please work with your IT department to ensure SAP SuccessFactors sites are added to any allow list and trusted site lists.
  • For more information, see 2088726 - Error - Antivirus Software Causing Issues with Application Functionality

See Also

Implementing and Managing Performance Management - Supported HTML for Performance Management Forms.

Keywords

SF, success factors, corrupted text, HTML, performance review, 360 multirater, en-US locale for standard elements in data model is missing, MTR-3057, PMR-3092 , KBA , csg_q , sf error messages gm , sf error messages pm , LOD-SF-PM-FRM , Forms & Templates , LOD-SF-PM-SYS , System Performance , Problem

Product

SAP SuccessFactors Performance & Goals all versions