Symptom
If a user attempts to open a document that is in a collaborative step (C-step) and is already being viewed by another participant, they receive an error message:
The document is currently being locked by another user. Please try again at a later time.
Environment
SAP SuccessFactors Performance Management
Cause
- Another user is currently viewing the document.
- A user viewed the form, but did not click the Save and Close or Close Without Saving buttons causing the session to remain cached on their PC and locked to other users until it times out.
Resolution
- The document remains locked until the user that has the form open:
- Clicks the Save and Close or Close Without Saving buttons
- Has the session time out
Additional Information
- Although multiple employees can have the same document in their inbox at the same time, only one person can open/access the document at a time.
- The error message will indicate the name of the user that the form is locked by. Currently the Collaborative Step lockout time is 60 minutes
- If a user simply closes their browser or walks away from their computer, the document is still locked until the user's session times-out.
- If Enable Auto Logout at Session Timeout is turned on, when the session times-out the changes made to the form will save and the document automatically unlocks.
See Also
KB article 2078741 - The Collaborative Review Process (C Step) - Performance Management
Keywords
SF, Success Factors, PMGM, PM, cstep, lockout time, forms locked, PMU-4121 , KBA , sf performance manage live forms , LOD-SF-PM-MAP , Routing, Route Maps & Workflows , Problem
Product
SAP SuccessFactors HXM Suite all versions ; SAP SuccessFactors Performance & Goals all versions