SAP Knowledge Base Article - Public

2078684 - Steps for Active Users Disappearing from Route Map - Performance Management

Symptom

  • This KB article focuses on Active individuals either disappearing or not showing up in the route map after proceeding to the next step.
  • The entire step is missing from the route map shown at the top of the form. Because these individuals are considered Active, they should be in the workflow.

Environment

SAP SuccessFactors Performance Management

Reproducing the Issue

  • The missing person in the route map could typically be any user, but in this example the employee step (E) will be used as this is the most common example.
  • Whenever an employee either tries to create a PM form for themselves or by mass creating for multiple users, it removes the employee from the route map, even though they are listed as active.

   Example: a PM form with the following route map

1.jpg

  • When the PM form for an active employee is created, the employee is removed from the route map.
  • As listed below, only the manager step remains because the system does not recognize the employee as active:
2.jpg 

Cause

  • This behavior is caused by the employee not belonging to the default permission group which controls basic functionality.
  • Although the employee is active in the system, they do not have the basic permissions which would identify them on a form’s route map.

Resolution

If the user is a Non-RBP based (Role Based Permissions):

If Role Based Permissions (RBP) are used:

  • Ensure the users belong to the default permission group.
  • The user will need to first be deactivated and then reactivated to ensure they are added to this group.
  • If this does not the SAP engineering group will need to correct this on the back end via a custom solution to add these employees to the default group permission.
  • Please open a case with Customer Success team.

If the user is Invalid or an Inactive User:

  • The behavior could cause random failures throughout the system.
  • It is impossible to define any logical cause as to why some steps seem to disappear while others are ok since this is a data issue.
  • This is preventable by ensuring all data changes are properly ordered and users in a route map are set as ACTIVE at the time of transfer and belong to the default user group permissions.
  • An Invalid user is any person who cannot log into the system.
    • If the user is set as ACTIVE but the manager was set as INACTIVE at the point in time, then the user will not be able to log into the system.
    • If the user cannot log into the system, the system is aware of this and will therefore skip the user in the route map.
  • If the user is not in the default user group the will be considered inactive and not part of the workflow.

Note: Please keep in mind this logic applies at the exact time of transfer. While the data file may have a user active at present, if the user was not at the exact time the form was routed the issue has already occurred.

Keywords

PMGM, PM, success factors, sf, routing , KBA , LOD-SF-PM , Performance Management , Problem

Product

SAP SuccessFactors HCM suite all versions ; SAP SuccessFactors Performance & Goals all versions