SAP Knowledge Base Article - Public

2078723 - Ratings Showing as Drop-down List Instead of Star or Circle - Performance Management

Symptom

  • This KB article provides an overview of changing certain rating options to stars based on the format they are in.
  • Why the rating options will become stars as opposed to other options such as a drop-down menu.
  • The rating options can appear as stars and other characters based certain criteria (demo, form, etc.).

Environment

  • SAP SuccessFactors Performance Management
  • SAP SuccessFactors 360 Reviews

Cause

There a several reasons why the Star/Circle ratings will appear as a dropdown list:

  • A rating scale of more than 5 points will cause the stars to convert to a drop down list. 
  • If the template has the option Hide numeric rating values (only show text labels) selected, see KB article 2078007 - How to hide numeric ratings in my Performance Form.
  • If you are using a reverse rating scale.
  • DropDown Rating has been explicitly mentioned in the form template configuration:

                     <scale-type><![CDATA[DROPDOWN]]></scale-type>

Resolution

  • Use a rating scalewith 5 or fewer points. 
  • Note: Using the "Unable to Rate" feature will add an icon seperate from the rating scale. See KB article 2479560 - How to Configure the Unable to Rate Feature.
  • Uncheck "Hide numeric rating values (only show text labels)" in the General Settings section of Manage Templates.
  • Reverse rating scale doesn't work with star rating format: Reverse Rating Scale is always selected using a dropdown menu.
  • Make sure to review the form configuration and set the scale type to 'null'as Star is the default rating scale type.

               <scale-type><![CDATA[null]]></scale-type>

Keywords

SF, PM, PMGM, success factors, icons, dropdown, Star , KBA , sf pm v12 rating , LOD-SF-PM-RAT , Ratings and Weights , Problem

Product

SAP SuccessFactors HCM Suite all versions ; SAP SuccessFactors Performance & Goals all versions