Symptom
- Errors are encountered during acquisition of .unx universe (single- and multi-source) in Lumira Desktop, users most commonly see the following:
Error in the query panel: Unable to initialize the DSL Service Provider. Ensure that the universe has not been removed, that you have sufficient rights to access it, and that the BI platform has a valid license. |
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When tracing, the following errors can be found in log file:
Could not load the selected universe : Unable to connect to service WebPlugin.WebiSession from server <server name> via CMS osca:iiop://<servername>;SI_SESSIONID=xxxxxxxxxxxxxx (FWM 01006) |
Could not load the selected universe : An unexpected error occurred. The exception thrown was: Unable to find servers in CMS <servername> and cluster "@<clustername> with kind fileserver and service null. All such errors could be down or disabled by the administrator (FWM 01014) (FWM 08010). |
Could not load selected universe: an internal error occurred while calling 'getSessionInfosEX' API (Error: ERR_WIS_30270) |
Could not load the selected universe :[Data Federator Driver] No data federation service was found. Reported error: 'com.crystaldecsions.sdk.exception.SDKException$OCAFramework: Unable to find servers in CMS <servername> and cluster@<clustername> with kind pjs and service DataFederatorService. All such servers could be down or disabled by administrator (FWM 01014) |
com.crystaldecisions.sdk.exception.SDKException$PluginNotFoundAtCMS: The 13 plug-in does not exist in the CMS (FWM 02017) (...) com.businessobjects.mds.services.solver.ConnectionSolverException: Unable to connect to the InfoStore |
Environment
- SAP BusinessObjects Lumira Desktop 1.x
- SAP BusinessObjects Business Intelligence Platform 4.1/4.2
Reproducing the Issue
- In Lumira Desktop, click File > New > SAP Universe Query Panel
- Log in to the BIP system
- Select a .UNX universe and click Next
Cause
- This behaviour can be caused in a number of ways; steps to resolve for each root cause can be found below
Resolution
- Behaviour might be rights-related; check whether the enterprise administrator account shows the same behaviour
- In traces and user interface, look for the following error messages:
- "Could not load the selected universe : Unable to connect to service WebPlugin.WebiSession from server <server name> via CMS osca:iiop://<servername>;SI_SESSIONID=xxxxxxxxxxxxxx (FWM 01006)"
- Cause: The Web Intelligence service is missing.
- Resolution: Create a new Web Intelligence Processing Server.
- "Could not load the selected universe : An unexpected error occurred. The exception thrown was: Unable to find servers in CMS <servername> and cluster "@<clustername> with kind fileserver and service null. All such errors could be down or disabled by the administrator (FWM 01014) (FWM 08010)."
- Cause: The Input Filestore service is missing.
- Resolution: Ensure IFRS is located under <BO Install directory>\SAP BusinessObjects Enterprise XI 4.0\FileStore\Input\XXX\XXX\XXX; restore it if required. Ensure the InputFileRepository service is enabled and started.
- "Could not load selected universe: an internal error occurred while calling 'getSessionInfosEX' API (Error: ERR_WIS_30270)"
- The DSL Bridge service is missing.
- Resolution: Create a new Adaptive Processing Server with the DSLBridge service.
- "Could not load the selected universe :[Data Federator Driver] No data federation service was found. Reported error: 'com.crystaldecsions.sdk.exception.SDKException$OCAFramework: Unable to find servers in CMS <servername> and cluster@<clustername> with kind pjs and service DataFederatorService. All such servers could be down or disabled by administrator (FWM 01014)".
- Cause: Data Federation service is missing.
- Resolution: Create a new Adaptive Processing server with the Data Federation service.
- "com.crystaldecisions.sdk.exception.SDKException$PluginNotFoundAtCMS: The 13 plug-in does not exist in the CMS (FWM 02017) (...) com.businessobjects.mds.services.solver.ConnectionSolverException: Unable to connect to the InfoStore"
- Cause: Connection server failure.
- Resolution: Restart 32 and 64 bit connection servers.
Keywords
KBA , BI-LUM-DIS , Lumira Desktop/Discovery , How To
Product
SAP Lumira, desktop edition 1.0