SAP Knowledge Base Article - Public

2087266 - Missing Route Map Step - A Route Map Step is Not Visible - Performance Management

Symptom

  • A Performance Management form is missing route map steps or a step was skipped.
  • Some PM forms have fewer steps than others.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Performance & Goals

Cause

There a several reasons why route map steps are missing, the most common are listed below.

  1. The form was routed with the Route Form tool using the option "Skip Step to continue the process:"

skip step to continue process.png

Note: When we route form using "skip to continue the process" the missing steps of the route map will not be visible in audit trail of the form. The origin step from where the form is routed to specific step will be visible as "skipped" in audit trail.

  1. A user in the route map is inactive or was inactive when the form was created or routed.
    • During form launch, manager change, or form routing, the SuccessFactors Application will automatically skip any step for which the there is no active user in the designated role (e.g. the next step in the route map is a matrix manager step but the subject either does not have a matrix manager assigned, or the assigned matrix manager is inactive that step will be skipped.) 
  2. The order of operations was incorrect during an employee import, the previous manager was made inactive prior to the new manager being assigned.
  3. The Manager only implementation check box was turned on for one or more user data imports, inactivating all non-management users.
  4. The step owner has not been grated the RBP permission "User Login", a user without login permission would not be able to access forms and therefore the system will skip the step. (See KBA 2410089 for more information)
  5. The first name and last name of the step owner is not maintained in Employee Profile.

Resolution

Most of the time, these issues can be resolved by correcting the underlying data and "rocking" the form using the Route Forms tool.

To rock a form,

  1. Open the Route Forms tool in Admin Center
  2. Use the search options to select the form(s) at issue.
  3. Route the form backwards to a step prior to the missing step
  4. If the data has been corrected, you should now see the steps that were missing, use the Route Forms tool to route the form to the desired step.

Keywords

skip, route form, route back, inactive, data, review, move on behalf of, SF, success factors, PMGM, rock, first name, last name, Username. , KBA , sf routing maps , LOD-SF-PM-MAP , Routing, Route Maps & Workflows , How To

Product

SAP SuccessFactors Performance & Goals all versions