Symptom
Users are receiving an "Invalid manager detected." error message when attempting to login.
Environment
SAP SuccessFactors HXM Suite
Reproducing the Issue
- Try to log into SuccessFactors;
- The error message prompts: "Login unsuccessful. Invalid manager detected. Please contact your local system administrator for assistance. Sorry for the inconvenience.".
Cause
- Manager ID associated to the user is invalid
- Manager status is inactive in UDF
- Manager field is set as "Mandatory: NO" in UserDirectorySetting
Resolution
You can either:
- Assign an active manager to the user or update the current manager status to active.
- Set the users manager to NO_MANAGER, if the user does not have a manager (e.g. the CEO of your company who will not have a manager or a temporary change of manager is required).
NOTE: These changes can be done via "Admin Center > Manage Users" (for non-EC instances) or "Admin Center > Employee Export & Import" (for EC instances).
- Additionally, check if the Manager field is set as "Mandatory: YES" in Manage Business Configuration.
- Go to Manage Business Configuration > Employee Profile > Expand "View Template" Open sysUserDirectorySetting > search for Manager > edit
NOTE: When this field is not mandatory in the UDF, users can be created, but cannot login, as they don't have a valid manager assigned.
Note: As of 2h 2023, system no longer check for Valid Manager when user is trying to login. Further information can be found on WNV Removed Validation on Invalid Manager | SAP Help Portal.
See Also
Keywords
invalid manager, login error, login unsuccessful, invalid manager detected, inactive manager, sf , KBA , sf login issues , LOD-SF-PLT-LPG , Log In Page Issues (Non SSO) , LOD-SF-PLT , Platform Foundational Capabilities , Problem