SAP Knowledge Base Article - Public

2088785 - "Not Within your Administrative Target Populations" error during Employees Import

Symptom

When trying to import users, an error message is received in the e-mail notification:

"The following users were not imported/updated because they are not within your administrative target populations:"

Environment

SAP SuccessFactors HCM Suite

Reproducing the Issue

  1. Process an employee import (manually or via scheduled job);
  2. The notification e-mail contains this error for some or all of the users in the file:
    "The following users were not imported/updated because they are not within your administrative target populations:"

Cause

The import operation failed because the user lacks import privileges for the specified target population.

Resolution

  • If the feature "Enable Control on Employee Import in Role Based Permission" disabled under Platform Feature Settings page, Employee Import target population are not controlled in RBP. Please see KBA 2187218 - Control Employee Import via RBP
  • If the import is being performed via "Manage Employee Import" feature, review the Employee Import Target population as per below:
    1. Go to Admin Center > Set User Information > Manage Employee Import:
    2. Enter the username performing the import and click "Search Users";
    3. Ensure that the data being imported matches the target population set for the Username performing the import.  If needed, adjust the filter options to include the new target population by selecting "All options";
    4. Save Definition for selected users;
    5. Perform the import again and this error will no longer appear once you have added the "All Options".
  • For customers that enabled the control of manage employee import under RBP (more info on this here 2187218), please follow below steps:
    1. Admin Center > Set User Information > Manage Permission Roles:
    2. Select the permission role of the user that wants to perform employee import;
    3. In the role click on "Permission" > Go to Manage user tab > Select Employee Import:
    4. Click "Done".
    5. Ensure the users affected are included within the target population (we suggest to do "All Employees" for target population).
    6. Click "Save Changes".

Keywords

BizX, SuccessFactors, PLT, Platform, UDF, User Directory File, employees import, e-mail, notification, error message, unable administrative target population permission, sf error messages, rbp, role based permissions , KBA , LOD-SF-PLT-UIM , Employee Import Issues , LOD-SF-PLT-JOBS , Scheduled Jobs , Problem

Product

SAP SuccessFactors HCM Suite 2505