SAP Knowledge Base Article - Public

2089562 - Users Can't See Shared Table Reports

Symptom

  • User A created a Table report and is trying to Share to User B. It saves successfully, but User B is unable to see the shared report.
  • In the Share screen/popup below, we can see that the report has been shared. However, it is not appearing on the Report Center list page for User B.

    2019-06-06_13-07-43.png

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

  • SAP Success Factors HXM Suite
  • Report Table

Cause

This behaviour is happening because the user does not have permissions to run report under the Reports Permissions section.

Resolution

  1. Check if the user you are sharing the report with (User B) has the permission to run the Ad Hoc Report Domain. See below: 
    If using Role Based Permissions, edit the role/s assigned to the user and make sure that there is permission to Run the Report Table Type you are trying to share.

    2019-06-06_13-19-48.png

  2. Grant the user or role the permission for the Ad Hoc Report Domain, to allow them to run the report

See Also

 KBA 2322495 - How to Grant Ad Hoc Report / Report Table Permissions to Users - Report Table

Keywords

Ad Hoc Reports, Role Based Permissions, User Based Permissions, Legacy Permisisons, Share, report sharing , KBA , sf adhoc 2.0 , sf adhoc reports , LOD-SF-ANA-ADH , Adhoc Reports & Report Builder , How To

Product

SAP SuccessFactors HCM Suite all versions