SAP Knowledge Base Article - Public

2092931 - Employee Central: Some Users do not Synchronize via HRIS Sync and do not Appear in Ad Hoc and ORD Reports (IS_EC_SYSTEM_OF_RECORD)

Symptom

  • Data for EC users versus non EC users.
  • You are in process of rolling out Employee Central for their organization, and not all users are in EC – they only have Employee Profile data loaded. The admin noticed that some of those non EC users had Biographical and Employment data loaded for them but when they tried to report on this data, they were unable to do so.  The EC data only showed online.

  • HRIS Sync - some users do not synchronize - why?
  • EC Ad Hoc reports - I cannot see EC data for some users in reports - why?
  • error message:  Message:{Global Identification Number (GIN) is invalid or user-id  is not associated to valid person in the system. Please import employment info record for user-id  first.

Environment

SAP SuccessFactors Employee Central

Reproducing the Issue

  • Change Data in EC and it is not synchronized to EP for "some" users
  • "Some" users are not available in EC Ad Hoc reports

Cause

Data was not created in the correct order, therefore in the database the user is still marked as "IS_EC_SYSTEM_OF_RECORD=0"

Resolution

In the b1402 release, SAP SuccessFactors rolled out a project where every time a Basic Import is performed, the system would automatically create a Biographical Information and Employment Details record in the database for the new user user. Although these records are created, the user is still flagged as "IS_EC_SYSTEM_OF_RECORD=0" to allow for EC and non-EC users to exist in the system (this is a requirement for some customers).

The system differentiates between EC and non-EC users by the use of the internal (database) flag on the Employment Info table called "is-ec-system-of-record" (IS_EC_SYSTEM_OF_RECORD) which defines whether this is an EC user or not.

When actual EC data is loaded for this non EC user, through UI or EC imports, this flag gets flipped and the user is then (from that point forward)treated as a regular EC user.

This is where the importance of the EC Data Imports comes into the picture. For a user to be treated as an EC user (IS_EC_SYSTEM_OF_RECORD=1) their data must be imported in the following order (otherwise it will not trigger the system to switch them to an EC user) -:

  1. Basic User Data                (Creates the UserID - the Employment)
  2. Biographical Information   (Creates the Person ID)
  3. Employment Details          (Associates the UserID with the PersonID - basically tying the Employment to the Person).

If the Biographical Info and Employment Details are loaded in the wrong order or are created via the My Employee Files UI, then they will not be linked and will not flag the user as IS_EC_SYSTEM_OF_RECORD=1.

This is why it is important to follow the correct process when creating users via import. See 2080146 - Employee Central - Employee Data Import Steps - Creating Users via Imports

How to Check if a User is an EC User

Please follow article 2584658 - How to Check if a User is an EC User using the Integration Center

FAQ

Q) HRIS Sync - some users do not synchronize - why? Will this mean that users flagged as "IS_EC_SYSTEM_OF_RECORD=0" will still synchronize data from EC to EP via the HRIS Sync?
A) No - users flagged as "IS_EC_SYSTEM_OF_RECORD=0" will not be considered by the HRIS Sync feature

Q) EC Ad Hoc reports - I cannot see EC data for some users in reports - why? Will this mean that users flagged as "IS_EC_SYSTEM_OF_RECORD=0" will still be visible in EC Ad Hoc related report?
A) No - only users flagged as "IS_EC_SYSTEM_OF_RECORD=1" will return EC data in these reports (note that the part of these EC Ad Hoc reports that pulls EP data will still work for non-EC users)

Q) EC ORD reports - I cannot see EC data for some users in reports - why? Will this mean that users flagged as "IS_EC_SYSTEM_OF_RECORD=0" will still be visible in EC Ad Hoc related report?
A) No - only users flagged as "IS_EC_SYSTEM_OF_RECORD=1" will return EC data in these reports (note that the part of these EC Ad Hoc reports that pulls EP data will still work for non-EC users)

See Also

  • 2080146 - Employee Central - Employee Data Import Steps - Creating Users via Imports
  • 2080730 - Employee Central: HRIS Sync - Troubleshooting Guide
  • 2319432 - Few users' records are present in "Personal Information" but are are missing in "Global Job Information"
  • 2363806 - Missing Users in Adhoc or Advance Reporting ( ODS or ORD) Reports
  • 2584658 - How to Check if a User is an EC User using the Integration Center

Keywords

IS_EC_SYSTEM_RECORD, ec imports, import employee data, IS_EC_SYSTEM_RECORD=1, IS_EC_SYSTEM_RECORD=0, ad hoc, users not returned in report, users did not sync, hris sync, IS_EC_SYSTEM_OF_RECORD=0, IS_EC_SYSTEM_OF_RECORD=1, ECT-45904,user-id  is not associated to valid person in the system. Please import employment info record for user-id  first, Message:{Global Identification Number (GIN) is invalid , KBA , sf employee_central , sf email , LOD-SF-EC-EDP , Import Employee Data (EC Core only) , LOD-SF-EC , Employee Central , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions