Symptom
After performing a search in the Learning admin side, when downloading the search results, the admin notices that the number of results in the file does not reflect the number of total records mentioned in the search results.
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Navigate to the Learning admin side >
- Perform a blank search in any entity menu >
- Example: People > Users >
- Perform a blank search >
- Note the number of total records >
- Click "Download Search Results" >
- Note that the results in this file are way below the number of total records mentioned in the UI.
Cause
There is a configuration limiting the results in the file and a backend infrastructure hard-coded limit.
Resolution
The number of rows that can be downloaded when using the "Download Search Results" option for Learning items, curricula, users etc. can be changed with the following configuration:
- System Admin >
- Configuration >
- System Configuration >
- Open the "Search" configuration in edit mode >
- Find and update the "resultMaxRowAllowed" config. value to the desired number of rows >
- Click "Apply Changes".
The configuration goes as below:
#This configuration limits the number of rows that can be downloaded from the Admin Search Framework results, and
#number of results shown in the Admin Power Search.
resultMaxRowAllowed=2000
PLEASE NOTE: This config. may have heavy performance impact for admins using system for larger amounts. Beyond this config., there is a backend infrastructure timeout. It is recommend to not set the value greater than 10000 and test the performance. If more is required, we recommend to utilize standard reports or create your own custom report instead (KBA 2320765).
See Also
Keywords
sap, sf, learning, lms, resultMaxRowAllowed, Download, Search, Results, excel, Microsoft, limit, blank, users, user, items, item, curriculum , KBA , sf lms , sf learning legacy , sf search , LOD-SF-LMS-ADM , System Admin, Global Variables, References , LOD-SF-LMS , Learning Management System , How To