SAP Knowledge Base Article - Public

2095654 - Failed to open Connection on LOV prompt for Crystal Reports

Symptom

Crystal Reports is prompting to logon to database while refreshing Crystal Report with Dynamic LOV. Followed by "Failed to open Connection" error after entering valid credentials.

Environment

SAP Crystal Reports 2013

Reproducing the Issue

  1. Start Crystal Reports Designer
  2. Login to BI Server
  3. Open report with Dynamic List of Values
  4. Refresh the report

Cause

Data Access rights are not granted to the User for the relevant Data Connection 

Resolution

  1. In Business View Manager find the relevant Data Connection for the LOV. (select the LOV in Repository Explorer window and click the "Show relevancy” button at the top-right corner of the Repository Explorer window, it should show you all the relevant objects including the DC)
  2. Right-click the DC in Repository Explorer Window and select Edit rights
  3. Click Preview button in the upper right corner of the dialog
  4. Notice the Data Access is unchecked and Denied for the User or User Group
  5. Explicitly grant the Data access to all required Groups
  6. Restart Crystal Reports

Keywords

login failed, Parameter box empty , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Problem

Product

SAP Crystal Reports 2013