SAP Knowledge Base Article - Public

2097629 - User's accessible views in SAP HANA are not appearing in SAP Lumira

Symptom

All of a user's accessible views in SAP HANA may not appear in SAP Lumira

NOTE: SAP Lumira, server version for SAP HANA and SAP Lumira Cloud are being retired and will no longer receive new feature investments.

For more information please refer to SAP Knowledge Base Article:

"2195103 - Certain SAP Lumira features are not supported in SAP Lumira Server for HANA and SAP Lumira Cloud"

Environment

  • Lumira 1.20
  • SAP HANA 1.82

Reproducing the Issue

  1. Create a analytical view in Hana studio
  2. View is not visible in Lumira

Cause

SAP HANA views that do not have an associated analytic privilege

Resolution

There are two possible reasons that views may not appear:

1) If a user has been granted an analytic privilege, and "Applicable to all Information
models" is selected, the user may expect to access all views available in SAP HANA.
However, SAP Lumira Server is not able to detect this flag. Users must be explicitly granted
an analytic privilege on a individual view.

2) The required privilege may not be set correctly in the SAP HANA view. SAP Lumira
Server is not able to detect SAP HANA views that do not have an associated analytic
privilege. To resolve this, navigate to the properties page of your SAP HANA view and
choose “Apply Privileges “ > “Analytic Privilege”.

Keywords

rights security blank empty , KBA , BI-LUM-SRV , SAP Lumira Server , Problem

Product

SAP BusinessObjects Lumira, desktop edition all versions ; SAP Lumira, desktop edition all versions