Symptom
You are not able to see output history for your business document XYZ even though you are able to see the preview of the same document.
Environment
SAP Business Bydesign
Reproducing the Issue
- Go to Customer Invoicing work center.
- Choose Invoice Documents view.
- Select Show - All Invoice Documents and search for XYZ( XYZ - Represent the created Credit memo ID)
- Edit the credit memo XYZ and navigate to the page Output History.
You will notice that no output of Credit memo is generated however you are able to see the preview with watermark Test Copy.
Cause
You have not maintained any output channel selection rule for the output of your business document. Hence no output is generated.
Resolution
To maintain the output channel rule to all instances of the selected business document, follow the below steps.
- Go to Application and User Management work center
- Choose the sub-view Output Channel Selection under view Input and Output Management.
- Choose Show Rules For Customer Invoice.
- Choose New option.
- Provide all mandatory information
- Choose the Business Document - Credit Memo.
- Save and Close.
Note : The Business Document should be Credit Memo.
However, if you want to maintain the output channel rule to of the selected business document specific to a business partner, follow the below steps.
- Go to the Account Management work center.
- Go to the View Accounts.
- Select Show - All Accounts and search for account ABC.
- Choose Edit and navigate to the page Communication.
- Choose the sub-view Collaboration.
- Under Business Document Settings select Customer Invoice/Credit Memo,
- Activate the control and maintain the Output Channel.
- Save and Close.
See Also
The same logic applies for all the below mentioned business document with one exception as shown below
- Customer invoice - Choose the Business Document - Invoice at step 6 of resolution while maintaining the Output Channel Selection in Application and User Management.
- Down Payment - Choose the Business Document - Down Payment Request at step 6 of resolution while maintaining the Output Channel Selection in Application and User Management.
- Proforma - Choose the Business Document - Proforma Invoice at step 6 of resolution while maintaining the Output Channel Selection in Application and User Management.
Note : If you want to maintain a generic rule for all business document Customer Invoice (Invoices, Credit memos and Down payments), do not select any value against Business Document at step 6 of resolution while maintaining the Output Channel Selection in Application and User Management.
KBA 1981810 - Invoice Not Sent via E-Mail and No Output History Available
Keywords
Customer Invoice; Output history; Preview; Collaboration; Down Payment; Credit Memo , KBA , AP-CI-CI , Customer Invoice , How To