Symptom
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Launching content from an icontent.do url displays error:
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Load content onto your iContent server.
- Build a content object which launch method url is pointing to this content:
Example url:
/learning/user/onlineaccess/icontent.do?Course=CUSTOM&url=/self-managed/folder/test.html - Create an item and add this content object.
- Assign this item to a user
- log in to the user and launch the item.
Cause
The URL prefix from the deployment location has not been set correctly.
OR
iContent was not fully setup.
- Although the content was on the iContent server, there are settings in LMS that need to be added:
System Admin > Configuration > System Configuration > ICONTENT - Settings that caused issue:
#Default configuration - Production
enabled=false
## iContent account configuration - To use iContent, you need to enable this configuration.
Resolution
There can be 3 scenarios on what the resolution is.
Scenario 1 - URL prefix issues
Please check the instructions from KBAs 2396085 - iContent Launch URL Prefix for each datacenter and 2251749 - How to set up Deployment Location in LMS for instructions.
Scenario 2 - iContent setup prior to 2018:
Configure iContent settings in System Admin > Configuration > System Configuration > ICONTENT
This information should have been provided to you by iContent team.
Example:
#Default configuration - Production
enabled=true
## iContent account configuration
iContentAccountDeterminationCriteria=REFERER,URL,DEFAULT
SessionServiceURL=https://icontent-entitlement.plateau.com/session/getSession
iContentAccountId=CompanyID
iContentAccountPrivateCertificateBase64=encryptedstring
iContentAccountName=Plateau iContent Backoffice Web Application
iContentAccountContactName=Content Services
iContentAccountContactEmailAddress=content.services@plateau.com
ValidateLaunchUrl=false
# Config for Staging Hostname
iContentAccount.stage.enabled=true
iContentAccount.stage.SessionServiceURL=https://icontent-entitlement.plateau.com/session/getSession
iContentAccount.stage.iContentAccountId=CompanyID
iContentAccount.stage.iContentAccountPrivateCertificateBase64=encryptedstring
iContentAccount.stage.iContentAccountName=Plateau iContent Backoffice Web Application
iContentAccount.stage.iContentAccountContactName=Content Services
iContentAccount.stage.iContentAccountContactEmailAddress=content.services@plateau.com
iContentAccount.stage.ValidateLaunchUrl=false
# iContent TMS Instance designation for Staging
iContentAccount.stage.LMSClientSystem=StageID
iContentAccount.stage.InvocationUrlMask=https://company-stage.plateau.com/learning/
iContentAccount.stage.LMSUrlMask=https://company-stage.plateau.com/learning/
Scenario 3 - iContent setup in 2018 or after
System Admin > Configuration > System Configuration > ICONTENT is no longer used. Please open up a Support case to validate the iContent internal configuration file to then engage the Operations team.
Keywords
lms icontent, content, alt launch error, alt=Successfactors, pcm, setup , KBA , LOD-SF-LMS-PCM , iContent , LOD-SF-LMS , Learning Management System , Problem