Symptom
- E-Signature is enabled in LMS
- In an integrated instance, java errors are encountered when recording learning using Electronic signature
Please report the following error to your system administrator:
org.springframework.security.oauth2.consumer.OAuth2AccessDeniedException: Error requesting access token. at com.plateau.tms.oauth2.consumer.impl.SFTokenServerClientCredentialsProfile.retrieveToken(SFTokenServerClientCredentialsProfile.java:106) Caused by: org.springframework.web.client.HttpClientErrorException: 403 Forbidden at org.springframework.web.client.DefaultResponseErrorHandler.handleError(DefaultResponseErrorHandler.java:75)
or
StackTrace is org.springframework.security.oauth2.consumer.OAuth2AccessDeniedException: Error requesting access token. at com.plateausystems.elms.framework.oauth2.consumer.impl.SFTokenServerClientCredentialsProfile.retrieveToken(SFTokenServerClientCredentialsProfile.java:106)
at com.plateausystems.elms.framework.oauth2.consumer.impl.SFTokenServerClientCredentialsProfile.obtainNewAccessToken(SFTokenServerClientCredentialsProfile.java:80)
Caused by: org.springframework.web.client.ResourceAccessException: I/O error: sf-rest-api-server; nested exception is java.net.UnknownHostException: sf-rest-api-server
Environment
SAP SuccessFactors Learning Management System
Cause
There is a mismatch between LMS User ID, Admin ID and BizX ID or the LMS user id is mapped to a different LMS admin id.
Resolution
Please make sure that the LMS User ID, Admin ID and BizX ID are all the same.
Example: Suppose BizX id is AdminSF, LMS User ID and LMS Admin should be AdminSF
Note: If issue still occurs, support team may open an internal ticket with the Operations Team to clear cache memory.
Keywords
SF, Success Factors, LMS, learning, COSD-11078, COSD-28426, COSD-25092, electronic signature error, token request, ResourceAccessException, API
, KBA , sf lms , sf learning legacy , LOD-SF-LMS-ESG , E-Signature , How To