Symptom
-
Opening an existing document or creating new document may result in the error:
"The engine failed to start before timeout. Restart the application. (HDB 10005)"
Environment
- SAP Lumira
Reproducing the Issue
- Open an existing document, or click "select a source" to acquire a data source for a new document.
Cause
- There is a number of causes for the error message.
Resolution
- Shut down SAP Lumira Desktop, make sure all instances of SPALumira.exe and iqsrv15.exe are down. You can confirm this with Process Explorer.
- Open “C:\Program Files\SAP Lumira\Desktop\SAPLumira.ini” and append “-Dhilo.iq.start.timeout=30000” without the double quotes.Terminate the line with a Carriage Return. This sets the startup timeout to 30 seconds; the value is expressed in milliseconds. Restart lumira.
- Adjust MaxPermSize setting in SAPLumira.ini: -XX:MaxPermSize=1024M
- Selecting a different dataset, or restarting the application (or operating system) usually resolves the error by freeing RAM (memory) allocation.
- In certain situations, removing a conflicting SybaseIQ client middleware installation can unblock the application.
- Deleting the folder "DataBase" (where the file Hilo.db is stored), followed by a restart of the application, will recreate the folder and should fix the issue. Path to file is C:\Users\<user>\AppData\Local\SAP\SAP Visual Intelligence\DataBase
- Adjust virtual memory (paging size) of your computer in system preferences.
- In some cases, an uninstall/reinstall of the software may be required. Please download the latest version from the marketplace or use the update function in the client. (File > preferences > auto-update)
See Also
Keywords
acquire import acquiring open intermittent sporadic time out HDB1005 HDB_1005 time out performance memory , KBA , BI-LUM-DIS , Lumira Desktop/Discovery , Problem
Product
SAP Lumira, desktop edition 1.0