Symptom
You have migrated Suppliers and after successful migration, you have observed that the Suppliers are not in sequence.
For Example:
100
101
103
106
Reproducing the Issue
- Go to Business Configuration work center
- Select Implementation Projects view or Overview.
- Search and Open the migration activity
- Execute Migration for the respective Migration File
- Check the Suppliers in Supplier view of Business Partner work center.
Cause
The gaps in the Supplier IDs are caused by the internal numbers drawn for the respective contact persons of the suppliers.
E.g. Supplier 103 might had two Contacts assigned to it (In the Contacts sheet of Supplier Migration). As both suppliers and contact persons are business partners, they both get their internal IDs from the same number range. So, the two contacts assigned to the Supplier 103 will have the ID 104 and 105 respectively.
Resolution
The system is working as designed
Keywords
KBA , suppliers , suppliers are not in sequence , SRD-CC-MIG-CNT , Migration: Content , How To