Symptom
- SAP Crystal Reports 2013 crashes on adding a second table to Progress OpenEdge connection
- Existing multi-tables reports work fine
Environment
- SAP Crystal Reports 2013
- Progress OpenEdge 10.2B
- ODBC connection
Reproducing the Issue
- Start SAP Crystal Reports 2013 application
- Create a Blank report and connect to Progress OpenEdge via ODBC
- Add any two tables and click OK
- The application "stopped working"
Cause
Known defect of the ODBC driver PGOE1024.dll documented in the Progress Knowledgebase: http://knowledgebase.progress.com/articles/Article/P184664
Resolution
(Resolution copied from the link above)
Upgrade the OpenEdge Client to 10.2B06 or Upgrade to OpenEdge 11.0 ODBC driver.
Both OpenEdge 10.2B06 and OpenEdge 11.0 use version 6.12.02.86 of the ODBC driver.
Workaround:
Rollback to version 5.30.00.109 of the Progress OpenEdge 10.2B Driver (PGOE1023.DLL) that is still present in C:\Progress\OpenEdge\bin.
Backup the Registry before making changes.
Option #1 - Change Registry so any new ODBC DSNs will use the version 5.30.00.109 ODBC driver
Locate the following Registry keys:
32-bit Windows
HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI\Progress OpenEdge 10.2B Driver
64-bit Windows
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ODBC\ODBCINST.INI\Progress OpenEdge 10.2B Driver
Modify the Driver and Setup entries and change PGOE1024.DLL to PGOE1023.DLL.
Option #2 - Modify existing ODBC DSNs
a) Delete and recreate existing ODBC DSNs after performing the steps in option #1.
OR
b) Locate ODBC DSN in
32-bit Windows
HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBC.INI\<Name of ODBC DSN>
64-bit Windows
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ODBC\ODBC.INI\<Name of ODBC DSN>
Modify the Driver entry and change PGOE1024.DLL to PGOE1023.DLL.
Keywords
Access Violation, multi-table query, shuts-down, collapse, , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Bug Filed