Symptom
System does not allow you to cancel the manually created credit memo.
Reproducing the Issue
- Go to Customer Invoicing work center.
- Choose the Invoice Requests view
- In the field find choose show all invoice requests and search for ABC. (ABC represents Document ID)
- Select the invoice and choose the button Cancel.
- You will get the error messages like:
ID of party with role Invoicing Unit missing
ID of party with role Sales Unit missing
Currency missing.
Item Missing.
Cause
While creating the manual invoice request if you forget to enter all the mandatory data like the account, sales unit and currency but if you fill only the product, the system allows you to save the credit memo with error messages and later you deleted the product also, so the status will become inconsistent.
Now if you try to delete or cancel the credit memo system will not allow. The only option is to make it consistent and cancel it.
Resolution
In order to cancel the document firstly you have to make the document consistent by entering the dummy details which are mandatory fields on the screen, Now once the document is consistent follow these steps.
- Go to Customer Invoicing work center.
- Choose the Invoice Requests view
- Choose show All Invoice Requests and search for ABC (ABC represents Document ID)
- Select the invoice and choose the button Cancel.
This will make the item status Canceled and the document header status to processed.
Keywords
KBA , AP-CI , Customer Invoice Processing , How To