Symptom
When checking inconsistent invoice request XYZ (XYZ represents the invoice request ID) the following error messages are shown:
- "Organization Sales Unit ID ABC must have organizational role Sales" (ABC represents the sales unit maintained in the invoice request).
- "Party with role Sales Unit does not belong to seller company EFG" (EFG represents the seller company of the invoice request).
You notice that currently the sales unit is not valid but was valid for the invoice date.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Customer Invoicing work center.
- Select the Invoice Requests view.
- Select invoice request XYZ.
- You can see that the status is inconsistent.
- Click the Check button.
The following Error messages appear:
- "Organization Sales Unit ID ABC must have organizational role Sales".
- "Party with role Sales Unit does not belong to seller company EFG".
- Go to the Organizational Management work center.
- Select the Org Structures view.
- Locate org unit ABC.
- Navigate to the Timelines tab.
- You can see that the org unit ABC is currently not valid but was valid on the invoice date of the invoice request.
Cause
This is the current system behavior.
The check for the validity of the sales unit is not dependent on the invoice date but depends on the current date.
Resolution
We have forwarded the request of the functionality to take the invoice date into consideration when checking the validity of the sales unit as feedback to our product planning process. We are continuously extending our products with new functions and appreciate your feedback. Unfortunately it is not possible for our Support Team to provide you additional information regarding the availability of this feature in a future release. For further information regarding your request please contact your sales contact (Account Manager/Customer Advocate/Solution Advisor).
In the meantime, you need to extend the validity of the respective sales unit to the current date in order to make the invoice request consistent and to be able to process the invoice request further.
Should the invoice request already be processed for example invoiced, you can ignore the inconsistency.
See Also
KBA: 2814513 - Your Invoice Request Is Inconsistent
Keywords
KBA , AP-CI , Customer Invoice Processing , How To