Symptom
When adding a new sales team member to a sales document, i.e. opportunity, you can save it without assigning an user to it.
Reproducing the Issue
- Go to Sales work center;
- Select Opportunities view;
- Open Opportunity ID ABC (ABC represents the ID of the Opportunity);
- Go to Sales Team facet;
- Click in Add Button;
- Select the Role, but do not add a Name;
- Click on Save.
You can save the document.
Cause
The system does not have a check for role creation on sales documents.
Resolution
This is the system expected behaviour.
If you need the object ID urgently in the Related Items facet of tasks you may contact your implementation manager to help with such request or approach directly the SAP Cloud Service Center.
You can find more details about the services offered by the Cloud Service Center on https://www.sap.com/services/application-development.html . You can contact the Cloud Service Center as follows:
If you are a partner: please use cloudsolutionpartner@sap.com or the Partnerfinder
If you are a customer: please use the little blue box “Contact Us” shown on the very right-hand side of https://www.sap.com/services/application-development.html, choose "Contact Us", choose "Services", choose "SAP Custom Development" and complete the page.
Note: The services of the SAP Cloud Service Center will be charged as packaged services based on fixed prices.
An alternative option may be to check the SAP Hybris Cloud for Customer Ideas Forum to submit an idea: https://ideas.sap.com/SAPCloudforCustomer
Keywords
KBA , LOD-CRM , Cloud for Customer , How To