Symptom
You are trying to clear G/L Account line items with Balance in Company Currency zero but the Clear option is not enabled.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to General Ledger work center.
- Click General Ledger Accounts view.
- Find the G/L Account.
- Click Edit and Select the Open Items on Selected Account.
- Select the open line items.
- You can see that the Balance in Company Currency is Zero but clear option is not enabled.
Cause
The issue is occurs because the Open Item Reference ID is not matching for both the line items. While clearing two or more items, below two things need to be checked:
- Open Item Reference ID must be same for all the line items or there should not be any Open Item Reference ID assigned to the selected items.
- Balance in Company Currency must be Zero.
Resolution
The issue can be resolved by first removing the assignment and then assign the existing open item reference ID.
Step -1: To remove the assignment for the open item, follow the below steps:
- Go to General Ledger work center.
- Click General Ledger Accounts view.
- Find the G/L Account and click Edit.
- Select the Open Item on Selected Account.
- Click Remove assignment.
Step -2: To assign the existing open item reference ID follow the below steps:
- Go to General Ledger work center.
- Click General Ledger Accounts view.
- Find the G/L Account.
- Click Edit and select the Open Items on Selected Account.
- Click Assign and select Assign Existing Open Item Reference.
After following the above steps check the Balance in Company Currency which should be Zero. Now you can see that the clear option is enabled and will allow you to clear the line items.
See Also
Keywords
open items; Balance in Company Currency; open item reference ID , KBA , SRD-FIN-GL , General Ledger , How To