SAP Knowledge Base Article - Public

2135145 - Distribution Channel Cannot Be Maintained in Account Master Data

Symptom

The distribution channel cannot be changed in the sales data tab of an account.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Account Management work center.
  2. Go to the Accounts view.
  3. Select Account XYZ (where XYZ represents the Account ID).
  4. Click Edit -> Sales Data 
  5. Go to the Sales Data tab.

The Cross-Account Sales Data checkbox is ticked and the line with the distribution channel cannot be changed.

Cause

As the Cross-Account Sales Data checkbox is ticked this distribution channel in combination with the sales organization is valid for all accounts and it is maintained in the Maintain Cross-Account Sales Data Common Task.

To check if any Sales Data information was determined from the Maintain Cross-Account Sales Data Common Task, it is required verify if the Cross Account Sales Data checkbox is ticked.

- If the Cross Account Sales Data checkbox is marked means that the information was determined from the Maintain Cross-Account Sales Data Common Task and the fields will be grayed out.

- If the Cross Account Sales Data checkbox is not marked means that the information was manually entered for the Account, being possible to edit the information.

Resolution

Maintain the distribution channel in the Maintain Cross-Account Sales Data Common Task

  1. Go to the Account Management work center.
  2. Go to the Common Tasks, select Maintain Cross-Account Sales Data.
  3. Select the row of the required sales combination, change the Distribution Channel.
  4. Save the change.

Afterwards, the updated distribution channel will be automatically updated in the existing accounts.

Keywords

distribution channel, maintain cross-account sales, account , KBA , AP-BP-BPT , Business Partner Template , How To

Product

SAP Business ByDesign all versions