Symptom
You are performing the Migration of Accounting Transaction Data and notice that payments that are migrated as part of Open Items Receivable/Payable are always migrated as positive amounts on the respective credit/debit side, regardless if it was maintained as a positive or negative value in the migration template.
Reproducing the Issue
- Go to the Business Configuration work center.
- Open the Fine Tuning Activity "Migration of Accounting Transaction Data" either via Overview or an open Project that contains the activity.
- Click on Migrate accounting transaction data using the migration tool.
- Mark the Migration Unit in question and click Execute Migration
- Select Migration Object "Open Items Receivable" and attach the the file containing an item with Document Type "Payment" and a negative value.
- Proceed through all further migration steps as instructed on-screen to complete the process.
- After finishing the migration, you see that the manually entered "-" sign has been ignored and the migrated item has a positive value when viewed in the Customer Account Monitor.
Cause
The system uses the Document Type rather than the leading sign to determine the credit/debit side of the item. As a result, the migration of a negative payment on Accounts Receivable (such as a return payment) is not possible.
Resolution
We recommend either settling the item in the legacy system before migration or recreating the item afterwards via these steps:
- Go to the Receivables work center.
- Open the Customer Accounts view, locate the Account in question and click View.
- Click on New Charge/Credit and configure the payment as desired.
Keywords
KBA , migration of accounting transaction data , open items receivable , SRD-FIN-ACP , Payables , Product Enhancement