SAP Knowledge Base Article - Public

2149141 - Reports related to surveys does not bring data if Users are applied as filter

Symptom

Reports related to surveys do not return data if users are applied as filter. When no user filter is used, the report returns data.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Learning

Reproducing the Issue

  1. Go to Admin> Reports >
  2. Select the report, it could be:
    1. Follow-up Survey
    2. Follow-up Survey By Individual Response
    3. Survey By Individual Response
    4. Surveys
  3. Select the "User" to be used as filter >
  4. Select the "Survey" to be used as filter >
  5. Run the Report >
  6. Once finished, the report data will be blank.

Cause

Reports related to surveys, by default, do not provide data in the report when selecting users IDs when the survey is set as anonymous.

Survey_is_anonymous.png

Resolution

Changing the survey not to be anonymous will return the user's response.
To do it, follow these steps:

  1. Go to Admin> Content> Surveys >
  2. Search and select the affected survey >
  3. Go to "Options" tab >
  4. Change the flag "Anonymous Surveys:" to "No".

See Also

2544815 - How to create an anonymous survey

Keywords

item, evaluation, report, blank, user, filter, survey, anonymous, follow-up, by, individual, response, surveys, lms, learning, result , KBA , LOD-SF-LMS-REP , Reporting Data , LOD-SF-LMS , Learning Management System , LOD-SF-LMS-ITE , Items , LOD-SF-LMS-EVA , Surveys , How To

Product

SAP SuccessFactors Learning all versions