Symptom
Reports related to surveys do not return data if users are applied as filter. When no user filter is used, the report returns data.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Go to Admin> Reports >
- Select the report, it could be:
- Follow-up Survey
- Follow-up Survey By Individual Response
- Survey By Individual Response
- Surveys
- Select the "User" to be used as filter >
- Select the "Survey" to be used as filter >
- Run the Report >
- Once finished, the report data will be blank.
Cause
Reports related to surveys, by default, do not provide data in the report when selecting users IDs when the survey is set as anonymous.
Resolution
Changing the survey not to be anonymous will return the user's response.
To do it, follow these steps:
- Go to Admin> Content> Surveys >
- Search and select the affected survey >
- Go to "Options" tab >
- Change the flag "Anonymous Surveys:" to "No".
See Also
Keywords
item, evaluation, report, blank, user, filter, survey, anonymous, follow-up, by, individual, response, surveys, lms, learning, result , KBA , LOD-SF-LMS-REP , Reporting Data , LOD-SF-LMS , Learning Management System , LOD-SF-LMS-ITE , Items , LOD-SF-LMS-EVA , Surveys , How To