Symptom
You noticed that the IDs assigned to each new sales document (opportunities, sales quotes, sales orders...) and activities (appointments, phone calls, tasks...) do not follow a logical numbering order (e. g. ascending order or descending order).
Environment
SAP Cloud for Customer
Reproducing the Issue
The following steps are only an example:
- Go to Sales work center
- Go to Opportunities view
- Click New to create a new opportunity.
- Enter data accordingly and click Save.
RESULT: You notice that the newly created Opportunity received a non-sequential ID (e. g. the last one you've created was 46810 and this new one is 46813).
Cause
This is the system standard behavior. There are no legal requirements to offer continuous and near number ranges for Sales Documents and Activities (like there are for e.g. Bills). Hence, the system architecture is not designed to offer a sequential range of IDs as this would affect the system's performance without any need.
This concept embraces behaviors such as: You click New for creating a new object (i.e. Opportunity) and then click Cancel without saving the object. However, the system had already automatically allocated an ID for this object that was eventually not saved.
Resolution
System is working as designed. There are no legal requirements to have the Sales Documents and Activity IDs created in a logical numbering order.
See Also
2535878 - Sales Order Number Range Begin Number below than 9000000000 not allowed: "Update for from number APCRM1_LEAN_SO_IN failed; interval is already in use"
Keywords
number range, ID, order, number order, sales quote, sales order, opportunities, appointments, tasks, , KBA , LOD-CRM , Cloud for Customer , LOD-LE-CQP-CO , Lean Sales Orders , How To