Symptom
During initial migration of customers, you have not marked (X) for the Complete Delivery field and you wants to enable this field. When you try to enhance this field using migration with mode Enhance Existing Records, the migration is successful but the field is not enhanced in the respective Accounts.
Reproducing the Issue
- Go to Business Configuration work center
- Select Implementation Projects view or Overview.
- Search and Open the migration activity Migration of Customers
- Execute Migration for the respective Migration File with mode Enhance Existing Records
Cause
The field Complete Delivery can not be enhanced because in Sales Data there can be Sales Organizations which are marked as Cross-Account Sales Data and update to Complete Delivery in that case is not allowed via Account screen.
Hence this is not used as enhancement relevant. Data passed will be ignored and default (false) is set all the time. So, the field "Complete Delivery" cannot be enhanced using migration.
Resolution
As a workaround, you can consider updating the field Complete Delivery using Mass Data Maintenance which you have already confirmed that it works.
Keywords
KBA , SRD-MD-BP , Business Partner , How To