Symptom
You want to create a new account responsibility in a corporate or private account using Mass Data Maintenance but it fails and you get an error message Only list complete transmission (LCTI) allowed for CUSTOMER-DIRECT_RESPONSIBILITY - DIRECT_RESPONSIBILITY_CTI
Reproducing the Issue
- Go to Mass Data Maintenance work center
- Export Customers
- Select the Account ID you need to update
- Go to Direct Responsibility tab
- Export Data to CSV File
- Open the file and add a line for a new contact.
- The field Direct Responsibility UUID[CURR_EMPL_RESP_UUID] can only be left blank since only the system can generate this field.
- Save
- Go to Mass Data Maintenance work center
- Import Customers
- Select your CSV file and Import Data to Tab: Direct Responsibility
- Upload
- You will receive the message: Data Validation finished successfully. No Invalid data found
- Execute Data Import -> immediately
- You will receive the error message No Customers imported successfully, X Customers failed. In the details you will get the error Only list complete transmission (LCTI) allowed for CUSTOMER-DIRECT_RESPONSIBILITY - DIRECT_RESPONSIBILITY_CTI
Cause
The Reason for the error message is that the field Direct Responsibility UUID is missing. This field is mandatory for Mass Data Maintenance however, only the system can generate it.
Resolution
This is a normal system behavior. Mass Data Maintenance cannot be used to create new responsibilities.
You can create new responsibilities manually when editing an account from the Account Management Work Center
or you can also use the migration tool from the Business configuration Work Center --> activity Migration of Customers (Migration mode : Enhance already existing records)
Keywords
KBA , lcti , customer-direct_responsibility , direct_responsibility_cti , new account responsibility , mass data maintenance , SRD-CC-MIG-DMC , Migration: Tool , How To