Symptom
Partners might report an issue that they are getting "Internal System error encountered while importing record “while importing Emergency contact.
Environment
Employee Central
Reproducing the Issue
The below error appears when you Import Emergency Contact without the relationship field
Cause
The error is appearing because if the “Relationship” field is not visible on the Emergency Contact Portlet then we will experience this error.
Resolution
1) In the Succession Data Model for HRIS element EmergencyContact - the field "relationship" could be configured as "visibility=none". So "relationship" field doesn't come up in the Import template. Hence there is internal system error on trying to import.
2) Please update "visibility=both" for field "relationship" in SDM as shown below for emergency contact and upload the SDM. Now "Relationship" field should come up in the Import template. Fill up the mandatory field relationship value and import now it should work fine.
Keywords
Emergency contact, Emergency contact error, Emergency contact import error , KBA , LOD-SF-EC-EDP , Import Employee Data (EC Core only) , LOD-SF-EC , Employee Central , Problem
Product
Attachments
Emergency Contact Import Error.docx |