SAP Knowledge Base Article - Public

2155761 - Error: "Failed to retrieve SSO2 logon ticket, please contact BW Administrator." when attempting to logon to SAP BW from Crystal Reports

Symptom

  • Error: "Failed to retrieve SSO2 logon ticket, please contact BW Administrator."
  • Fails to connect to SAP BW from Crystal Reports.
  • It is possible to logon to the SAP BW System from Crystal Reports when using a different SAP user, but fails with other users.
  • When attempting to create a new report off an SAP BW BEx Query in Crystal Reports, it fails to connect to SAP BW, and generates the following error:
          
        "Failed to retrieve SSO2 logon ticket, please contact BW Administrator.
          COM exception caught in CExtToolBar::InitOpenSaveDialog(). HR=0x90000001
          COM exception caught in CExtToolBar::InitializeGlobalData(). HR=0x90000001"

Environment

  • SAP Crystal Reports 2008
  • SAP Crystal Reports 2011
  • SAP Crystal Reports 2013
  • SAP Crystal Reports 2016

Reproducing the Issue

  1. In Crystal Reports, under the SAP menu, select "Create New Report from a Query..."
  2. In the "SAP Logon" window, select the SAP BW System to connect to, and click "OK"
  3. Enter the SAP User name and password.
     
    It then fails to connect, and generates the error:
      
    "Failed to retrieve SSO2 logon ticket, please contact BW Administrator.
     COM exception caught in CExtToolBar::InitOpenSaveDialog(). HR=0x90000001
     COM exception caught in CExtToolBar::InitializeGlobalData(). HR=0x90000001" 
      
    SAP BW Logon 01.png

Cause

  • CR designer 2013/2016 may used with an unsupported SAP GUI version. For more information visit PAM at here
  • This error occurs due to one of the following reasons:
    • Crystal Reports uses the Dialog mode, and the User Type is not set to Dialog for the user. For example, it is set to "Service"; and/or
    • If you are using Single Sign On to login, the SSO ticket generation is not enabled on the SAP BW System.

Resolution

  • Set the User Type to: Dialog, to be able to use the SAP User account to login to SAP BW from Crystal Reports:
       
    Important Note: 
    The following steps are generally performed by your SAP BASIS Administrator, and it is provided for informational purposes only. We recommend to contact your SAP BASIS Administrator to perform the change.
       
    1. Logon to the SAP System using an Administrator account.
       
    2. Type transaction: SU01, to go to the User Maintenance.
       
    3. In the :User Mainteance: screen, enter the SAP User name, and click "Change"
        
    4. Under the tab "Logon Data", set the "User Type" to: "Dialog" 

         
    5. Save the change.
                  
         
          
  • If you are using SSO to login to SAP BW System from Crystal Reports, then the SSO ticket generation is not enabled on the SAP BW System.
    For further details, see the SAP Knowledge Base Article:
        
    1430575 - Error: 'Failed to retrieve SSO2 logon ticket, please contact BW administrator.' when attempting to open a report saved on an SAP BW System in Crystal Reports
      

Keywords

CR, SAPBW, BEX query, SAP BW MDX Query , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Problem

Product

Crystal Reports 2008 V1 ; SAP Crystal Reports 2011 ; SAP Crystal Reports 2013 ; SAP Crystal Reports 2016