SAP Knowledge Base Article - Public

2156093 - Some users are unable to run or create Ad Hoc Reports due to an Application Error

Symptom

  • When some users try to create or run any Ad Hoc report, the action fails with an Application error.
  • The same report worksfor other users with similar / same permissions

Error message:
An application error occurred. Please try again later, or notify support (with the error information of errorId=XYZ, timestamp=123, and the version information from the current screen) if the issue keeps occurring.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP SuccessFactors HCM Suite 
    • Ad Hoc Reporting

Reproducing the Issue

  1. Login to the instance with the affected User
  2. Analytics - Reporting - Ad Hoc Reports
  3. Try to Run or Create a new report
  4. The following error message may occur: An application error occurred. Please try again later, or notify support (with the error information of errorId=XYZ, timestamp=123, and the version information from the current screen) if the issue keeps occurring.

Note: The report works fine with other users.

Cause

The User configuration may not be as expected.

Resolution

Such error may occur only for certain Users and Ad Hoc report if the Time Zone is not set for the User.

In this case, the User did not have the Time Zone and Default Locale defined and the issue was solved by configuring it.

The configuration may vary for Employee Central (EC) and Non Employee Central instances.

For standard Customers (without EC)

  1. This can be done/checked via Admin Tools - Manage User – Time Zone / Default Locale
    • Manage User.png

For Employee Central Customers (with EC)

  1. The Time Zone can be configured/checked via the Employee Profile (My Employee Files - Profile)
    • timezone from EC.jpg

Alternatively it can be configured to populate the location via the Update Employee Records and synch as per KBA 2080587

  1. The Time Zone and Default Locale can also be configured/checked via the Admin Center as follow:
  • Import Employee Data > Basic Import then fill the Time Zone and Default Locale per user
  •  import employee data.jpg
  • Employee Export – Export User File the Time Zone and Default Locale is visible in the respective columns.
    • Employee export.jpg
  • User directory file result

    User Directory1.png

Keywords

Application, error, Ad, Hoc, table, report , KBA , application error , LOD-SF-ANA-ADH , Adhoc Reports & Report Builder , Problem

Product

SAP SuccessFactors HCM suite all versions