Symptom
The Delivery Status of the sales order item is showing as In Process and overall sales order status is not as Completed even on canceling the related contract items.
Reproducing the Issue
- Go to the Sales Order work center.
- Go to the Contract Template view and in the Show field select All Template and search with TEM (where TEM is the Contract Template ID).
- Edit the Template and go to the General tab.
- Here under the General Information the Entitlement Product as ENT is maintained (where ENT is product id) and in Organizational Assignment session the Sales Organization as SAL and Distribution Channel as DIS is maintained (where SAL is Org Id and DIS is Distribution channel id).
- From the Common Task select New Sales Order and create sales order for same product ENT ,with sales org as SAL and distribution channel as DIS as is in contract template TEM and Save the sales order.
- Now click on the Release button to release the sales order ABC (where ABC is the Sales Order ID created ).
- This will create the contract EFG (where EFG is the Contract ID).
- Go to the Contract view and edit the contract EFG and in the General tab set the Cancelation Reason to Complete the Contract.
Once you complete the contract, the delivery status of the related sales order items remains as In Process and sales order is not Completed.
Cause
In order to finish the sales order item's Delivery Status and complete the sales order, you need to perform action: Submit-> Release or Send Order Confirmation to Account within the contract EFG, not canceling the contract.
Resolution
- Go to the Sales Order work center.
- Go to the Contract view and search for the contract EFG and click on the Go button.
- Edit the contract EFG and perform action :Submit-> Release or Send Order Confirmation to Account.
This will finish the sales order item's Delivery Status and also complete the sales order overall status.
Keywords
KBA , AP-SLO , Sales Order Processing , How To