Symptom
Error in Boomi process when connecting to the SMTP host in Boomi.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
Boomi
Reproducing the Issue
Error received when trying to connect to Successfactors SMTP Server.
Cause
Incorrect configuration of connection step for SMTP mail server.
The connection in Boomi was set up incorrectly as shown below.
You do not need to maintain username and password for SF mail connection
Only the host and port need to be maintained
A user name and password isn't required because an email will be sent from boomi servers via SMTP endpoint as mentioned in the process
The Boomi server and SMTP server are both in SF network and firewall, hence it doesn't require explicit user authentication
Resolution
- Enter Boomi instance
- Go to Build tab
- Click on the SMTP connection
- Make sure that just the host and port are specified
- The host name will depend on the data center which you are on
- The port is number 25
- If you do not know the host name, please create a customer support case and it will be provided to you
See Also
2257038 - Successfactors SMTP hostnames and port for all Data Centers
Keywords
Integration; SF; Mail connection; Mail server; Successfactors; SFSF; , KBA , LOD-SF-INT-BPI , Dell & Boomi Infrastructure , LOD-SF-INT , Integrations , How To