SAP Knowledge Base Article - Public

2160784 - Unknown Error in Batch Upload of Photos - SuccessFactors Employee Profile

Symptom

Batch Upload of Photos completes but returns an 'Unknown error' for a single Photo and terminates upload for the rest of the photos with error 'Process terminated, image not processed'

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Unknown Error.PNG

 

Environment

SAP SuccessFactors Employee Profile

Cause

This error occurs due to one of the following reasons:

  1. The Photo does not meet the following requirements:
    • Maximum file size: 2MB
    • File format: JPEG
  2. The Photo is corrupted:

This can be verified by opening the source file and the error displayed would be that the image is either damaged or corrupted as shown in the screenshot

Corrupt Image.PNG

Resolution

Based on the cause of the error, following are the respective solutions:

  1. Edit the Photo to meet the requirements of Size less than 2 MB and format of JPEG
  2. The Photo must be replaced with the right one that is not corrupted. Please refer to KBA 2203904 on converting photos.

Once the appropriate action has been taken, re-run the job for the files starting from the one that failed.

See Also

2094242 - Photos: How to Upload and Edit Live Profile Photos (Personal Information) Single Upload, URL Import & Batch FTP Import - Employee Profile

Keywords

Unknown Error; Batch Upload of Photos Failing; Process terminated; image not processed; profile photo, profile picture, photo , KBA , LOD-SF-EP-PHO , Photo Management , LOD-SF-EP-JOB , Scheduled jobs , Problem

Product

SAP SuccessFactors HCM Suite all versions

Attachments

Corrupt Image.PNG
Unknown Error.PNG