Symptom
- After Integrating Jam into LMS, administrators are still not able to search catalog or add Jam groups to Items.
- When searching catalog, you see this error.
- When adding Jam Groups to an item this error is displayed
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP SuccessFactors Learning Management System
Reproducing the Issue
- Prerequisites to integrate JAM with the LMS should be met:
- JAM and BizX must be integrated
- BizX and LMS must be integrated
- Configuration on the LMS Administration (System Admin>Configuration>System Configuration>LMS_ADMIN)
- Changes to LMS_ADMIN config file: jamIntegrationEnabled = true
- Changes to BizX config file with the (System Admin>Configuration>System Configuration>BizX): successFactorsCubeTreeBaseURL='according to the correct server mapping'
example: successFactorsCubeTreeBaseURL=https://jam##.sapjam.com (where ## is the data center the customer server is located)
Cause
The Jam API has not been Enabled in JAM Admin settings
Resolution
- In BIZX Home, from the dropdown menu select JAM
- Under Account Settings select Admin > Product Features > Features
- Scroll to Feature Management
- Make sure that Enable API is checked.
Note: Disabling the API feature will prevent access to your Jam environment via the Jam API and will prevent access using the mobile clients
Keywords
LMS, JAM integration, Enable API, Feature Management, successFactorsCubeTreeBaseURL, jamIntegrationEnabled, unable to connect to JAM, verify JAM integration , KBA , LOD-SF-LMS-JAM , Integration with SAP Jam , LOD-SF-LMS , Learning Management System , LOD-SF-INT , Integrations , LOD-SF-JAM , SAP Jam , Problem
Product
SAP SuccessFactors Learning all versions