Symptom
Problem: Time Off Calendar Keeps Running
This is the MDF object that is used to display the status of a running Calendar job in the Manage Time Off Calendars page. Find the job that is still "Running" and use its “Time account externalCode” value to find the same record in the Manage Data UI. Which will give us the user ID.
There will be one or more than one user record which need to be set as finished. Update the record i.e. set the status to Finished and save.
Environment
Environment:
Employee Central: Time Off (EmployeeTime : Time Off Request)
Reproducing the Issue
Issue Description:
If an accrual is executed and the accrual calendar job keeps running for days or for a very long time.
Cause
Root Cause:
This is likely caused because of the time account is not updated for the users after accrual ran.
Resolution
Solution:
First we need to check jobs in Provisioning > Monitor Job for "Time Account CalendarRun" jobs.
Go to Admin Tools > Manage Time Off Calendars, here you can check the status for all the accrual ran for calendars.
If there still see a job running: Navigate to Admin Tools > Import and Export Data (the MDF one) and export the data for object "Time Off Account Change Calendar" object.
This is the MDF object that is used to display the status of a running Calendar job in the Manage Time Off Calendars page. Find the job that is still "Running" and use its “Time account externalCode” value to find the same record in the Manage Data UI. Which will give us the user ID.
There will be one or more than one user record which need to be set as finished. Update the record i.e. set the status to Finished and save.
Refresh the Manage Time Off Calendar Page, the calendar will have its status Finished.
Keywords
Time off Calendar still running EmployeeTime calendar , KBA , LOD-SF-EC-TIM , Time Off , Problem