SAP Knowledge Base Article - Public

2162846 - Error: Failed to contact the extension repository at: <URL> in Lumira

Symptom

  • Attempting to access the Lumira Extensions Manager (File | Extensions) results in the error:

    "Failed to contact the extension repository at:
      http://127.0.0.1:49217/extensions_repository/repo/1.20.0/repository.json. Verify your network
      connections and proxy settings by trying to reach this URL using your browser."
  
   
    SAP Lumira - Data Extension Error.png

Environment

  • Lumira Desktop

Reproducing the Issue

  1. In SAP Lumira Desktop, under the menu "File", select "Extensions"
  2. It then displays the error:
      
      "Failed to contact the extension repository at:
        http://127.0.0.1:49217/extensions_repository/repo/1.20.0/repository.json. Verify your network
        connections and proxy settings by trying to reach this URL using your browser."

Cause

  • Lumira Network Preferences were set to "Use System Proxy Settings", and had no Proxy defined.

Resolution

  • In Lumira, set the "Network Preferences" to either "No Proxy", or "Manual Proxy Configuration"
      
    1. In Lumira, under the menu "File", select "Preferences"
    2. In the "SAP Lumira Preferences", select the "Network" options.
    3. Set the Proxy Settings, if you have a proxy at your company, otherwise, select the option "No Proxy", and click "Done"
         
         
        SAP Lumira - Proxy Settings - 02.png
         
       
      You will then be able to use the Data Extensions Manager.

Keywords

vis charts graphs , KBA , BI-LUM-DIS , Lumira Desktop/Discovery , BI-LUM-SRV , SAP Lumira Server , BI-LUM-OD , SAP Lumira Cloud , Problem

Product

SAP Lumira, desktop edition 1.0