Symptom
When we hire an employee using "Add New Employee" wizard, a "Manager cycle detected" erro appears as we click the "Save" button.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Employee Central
Reproducing the Issue
This error does not appear if trying to add a manager as system admin through Job History --> Make Correction.
It only appears when trying to add a manager through Add New Employee in the system.
Cause
This is a data issue. There is a circular loop with the manager that is being added/updated to as one in the cycle.
Resolution
There are two ways to check for a manager cycle:
Via Check Tool:
- Admin Centre > Check Tool (If you can't find this, then please grant permissions by following this KBA)
- In the Application Dropdown, choose User Management
- Click on the User Hierarchy Dropdown
- Click on No Manager cycle exists for the user, and enter the user when prompted who you want to run the check for
- Do the same for No second manager cycle exists for the user.
- Click on Run Check
Manually sorting through the hierarichy:
- Check the Job Information of the user whom you are trying to add as Manager for the new hire.
- Note down his name, and then start looking at his Job Information to find out who is his Manager.
- If you keep doing this for the Manager's Manager and so on, you will figure out a cycle of users, and that is the problem.
- Once you figure it out, correct the Manager for one of those users to break the cycle.
Keywords
Manager Cycle, Second Manager, No manager cycle exists for the user, No second manager cycle exists for the user, User Hierarchy, User Management, Check Tool, manager cycle error appearing, Manager Cycle Detected. Please try again , KBA , LOD-SF-EC-HIR , Hire & Rehire Wizards , LOD-SF-EC , Employee Central , Problem