Symptom
- Steps to be performed by customers before and after refresh activity for the SuccessFactors Learning Management System.
- Best Practices and Frequently Asked Questions on LMS Instance Refresh requests.
- Download the latest LMS Instance Refresh form.
Note: The manual refresh process is only an option for specific scenarios where the Instance Refresh Tool (IRT) cannot be used like:
- Refreshes that cannot be scheduled in the Instance Refresh Tool due to its technical limitations.
- Refreshes that were scheduled using the Instance Refresh Tool but have failed or gotten reverted for any reason.
For more information on the Instance Refresh Tool please see the KBA 2835061.
IMPORTANT: Before proceeding with a partial Learning refresh, please go through KBA 3682524 - Impact of Partial Refreshes on Learning Data.
Environment
- SAP SuccessFactors HCM suite
- SAP SuccessFactors Learning
Cause
- Refresh Activity is a full data copy from one database to the other. There is currently no way to select what is copied over and omit particular objects (i.e., users, administrators or configuration).
- After Refresh activity, customers may face issues related to integration, Connectors, FTP, etc. This happens because the configuration files of the Target instance have been overwritten with the Source instance configuration.
- After the refresh, the Target instance will have its OAuth Client Secret overwritten by the Source's. If OData API is used in the Target instance, it is mandatory to generate a new client secret to avoid any issues.
- To avoid such issues, refer to the steps provided in this KBA to be followed before and after the refresh activity.
Resolution
Best Practices
- Refresh requests must be requested through a MEDIUM priority case under LOD-SF-LMS component and include the filled in Instance Refresh form (see 'Attachments' section) signed as an attachment.
- It is necessary to allow a minimum of 10 days (Business Days) notice to our Operations team to have a Refresh booked in. They will review the request and advise on the availability for the Refresh to be carried out and to approve physical completion date/time.
- Refreshes requested for 'as soon as possible' will be assigned the next available time slot. If your preferred date/dates is not available Operations will advise on the next available date.
- Refresh activity overrides all the data, configuration files and other configuration settings in the target environment and adds source data into it. Please see the IMPORTANT note below to see what data is reverted back from scripts after the refresh is completed.
Source is the environment from where the data is being copied and Target is the environment in which the data will be pasted. - The Target environment must be on the same or newer version than the Source environment.
- During refresh activity, the source LMS environment will still be available for users and admins. For example, if you have requested to copy Production data into staging environment, it will not affect Production environment availability. During the activity schedule, you can access Production environment.
- Why a refresh? for instance, you refresh your stage instance with production data so that you can test new configuration or functionality with actual production data before implementing the change in production environment.
- When requesting a refresh for LMS you should also refresh the related Bizx instance and vice versa to avoid data, access issues (sometimes naming conventions, user IDs and admin IDs differ between environments which can cause issues if we only refresh LMS or Bizx).
IMPORTANT
As a part of manual refresh process, we run script that automates most of the processes in the system and avoid manual work. In case there are some configurations that are not covered, we suggest that you back those up manually. We will ask that you complete the pre and post manual refresh activities and inform us if you see issues post the completion of the refresh process.
The automation scripts will back up and revert the following:
- All Configuration files under System Configuration.
- Note: Internal iContent configurations are copied over to the new tenant and then restored, the iContent SFTP data such as files and folders are not modified in any way.
- Along with these, Content deployment locations, Entity configuration, External learning request and VLE configurations that are in System Administration> Configuration are restored from the target instance
- Entity configuration will be backed up and restored from the Target tenant schema.
- The Mail Configurations: Admin Email Address, Student Email Address, and backend configurations such as the Mail Server.
- Email notifications will be restored in Target instance post-refresh, and status of "Enable Email" will be set as it was prior to refresh in target.
- We clear all emails from target environment, but User synchronization job will be executed post refresh to synchronize user data from BizX to Learning which could update user email addresses in the target.
- The REPORT_DEVELOPER Role (however, it will still need to be manually reassigned to any admin account post refresh).
- All the previously enabled customer facing APM Jobs (all APMs under Learning Administration > System Administration > Automatic Processes) are disabled in the target instance after any refresh.
- Within 14 days after the refresh, the "Restore Recurring Jobs Status" button will be available under Learning Administration > System Administration > Configuration > Global Application Settings > Scroll to the end of page. This button will re-enable the APM jobs that were disabled because of the refresh activity.
- System owned APMs and Recurring Jobs (whose owner is "AUTO-SCHEDULER") will be backed up and restored post-refresh.
If any of these were not done correctly, please inform the Support Engineer that is working with you on the manual refresh.
Before Refresh Activity:
Before initiating an Instance Refresh (IRT) or Manual Refresh, customers using SAP SuccessFactors Learning Management System (LMS) must ensure their system is properly prepared to avoid validation errors.
If a Learning instance is not integrated, post-processing activities are not required. These activities are designed to ensure data consistency across integrated systems, and in cases of partial refresh, they pose no concern.
What You Need to Know
To avoid refresh failures, it's important to check whether a key job—Employee Export Job—exists in your target instance.
This applies specifically to customers using LMS with either:
- Platform (PLT)
- Employee Central (EC)
1. For LMS + Platform (PLT) Customers
✅ If the Employee Export Job exists in the target instance and is scheduled with a future date: You’re all set. No action is needed.
❌ If the job is missing or not properly scheduled: Please work with your implementation partner or SAP Professional Services to configure it correctly before initiating the refresh.
2. For LMS + Employee Central (EC) Customers
⚠️ A valid Employee Export Job must exist in the target instance for the refresh to proceed.
Without this job, the refresh will fail.
This applies to both IRT and manual refreshes, including full and partial refreshes. This requirement is in addition to any existing Employee Export Job you may have scheduled in Integration Center, as the current refresh process does not recognize those jobs.
📌 Temporary Workaround (before 2511 Release): A placeholder Employee Export Job can be created in the target instance to bypass the validation.
🛠️ For setup guidance, please refer to: KBA 2716723 – How to Create the Employee Export Job: Engage your implementation partner for assistance.
📝 Important: If you do not have an implementation partner, the LMS Support team can assist with creating the placeholder Employee Export Job until the 2511 release.
Steps #1,2,3,4,5 are optional. If you do not disable it pre-refresh, the scheduled jobs will be copied over to the Target instance, and you need to ensure that you disable them afterwards if they do not need to run.
If you do disable them in the Source environment prior refresh, then they will be disabled in the Target environment as well, and you will need to enable the ones you do need to run post-refresh.
In case of notifications on step #2, please note that if you choose to not disable it before the refresh, users may receive some notifications from Target and Source instances after the Source is copied to Target. If this is something that has a huge impact on your business, we recommend to disable it before the refresh process.
- Important Change: Take the following steps in the Source environment to have backup access to the Target environment post-refresh in case there are some configuration issues. These steps do not have to be done due to the automatic scripts as mentioned above but can be done as a contingency plan.
- Access the Source environment
- Go to Learning Administration > System Administration > Security > Administrators > Search or create a new Administrator account
- In the Administrator record that was just created or accessed, go to the Assigned Roles tab and make sure that the ALL and ALL_CONNECTOR roles are assigned
- In the Summary tab, make sure to associate a Related User. The Related User CANNOT be a user account that is managed in BizX. Skip to Step 4 if you know the Related User is not managed in BizX
- To validate if the account is managed in BizX, go to the User record under People > Users > Search, and access the user record. If the user is managed in BizX, a banner at the top of the User Details tab will indicate this. The Password field at the bottom will also be gone.
- If there is no user that can be used, go back to People > Users > Select Add New, and create a new native LMS user. Associate the user to the admin.
- Go to People > Users > Search for the user, and access the record
- Scroll down in the User Details tab until the Password field is visible, and set a new password
- Save the changes.
- Take backups of configuration files from the Target instance. These steps do not have to be done due to the automatic scripts as mentioned above but can be done as a contingency plan.
- Go to System Admin > Configuration > System Configuration.
- Open each file in edit mode, copy paste the content into notepad, and save as txt.
- We recommend taking backups of all files, but if you only want to backup the relevant ones, we recommend BIZX, CONNECTORS, REPORT_SYSTEM, and iContent.
- Confirm you know your SFTP password for the Target instance (in case you are using separate SFTP accounts for separate instances).
- Recurring reports:
- Please note that recurring report jobs will be copied over to target environment.
- All recurring report jobs are disabled after the refresh process in the Target system.
- If there is a need to edit/delete recurring report jobs, please follow instructions in 2250223.
- Please keep your logos handy. You need to upload them at the following location after refresh activity. Note: Labels, QuickGuide images, Company logos, and custom thumbnails are not backed up or stored in the LMS database. Therefore, you need to have these files available to upload them in the LMS Target instance after the refresh.
- Take a backup of all Deployment Location screen from the Target instance.
-
- Navigate to Content > Deployment Location.
- Open the file in edit mode, copy paste the settings into notepad, and save as txt or take screenshot.
- Please note that the password is encrypted in Deployment Location, so the copied password should be corrected manually.
Note: VSaaS (validated) target systems should download the IQ report as needed prior to refresh as the IQ report will show the Source URL/info post-refresh.
After Refresh Activity:
Important: If your Learning tenants have IAS enabled, the steps mentioned in the guide must be completed for user data to sync.
- Validate and update all configuration files with the backup files in the Target environment as needed. This will help in avoiding new issues related to integration and Connectors after refresh activity.
- Please note that for SFTP, password details are encrypted in the file and do not actually show the real value. Copying and pasting may not be enough, and you will need to input in the file the actual values again and apply changes.
- Please note that the email masking is done during the BizX refresh, and the LMS users records will be updated once you restore the connectors and the data between BizX and LMS is synchronized.
This will not take care of admin emails, which should be deleted manually or replaced in bulk using the admin connector. - Update your company logo.
- Login into LMS as Admin >
- Go to System Administration > Application Administration > Images >
- Upload your company logo and other images as needed.
- Delete any recurring report jobs as needed if not performed in pre-refresh steps.
- Purge Emails: These are the emails which were generated but not yet sent out in the Source environment, and they have now been copied over to the Target environment and need to be deleted.
- In the Learning Admin interface, select System Administration > Manage Email > Manage Unsent Emails >
- Select 'Delete Unsent Emails'.
- Revert back Deployment Location settings in Target LMS.
- Go to System Administration > Configuration > Content Deployment Location> Refer to the backup screenshot and revert back the settings.
- Please note that the password in the backup screenshot is encrypted. You need to input the correct iContent account password manually.
Notes:
- The Custom Labels and Customizations on the User Landing Pages (including Custom Tiles) are not copied from the Source to the target LMS environment and will need to be restored manually.
- Customers are responsible for recreating/set them up all over again on the Target instance post-refresh. As a suggestion, you can take screenshots and copy the source code of the custom tiles from the Source environment, and after the refresh, use them to restructure and customize the Landing Pages and Custom Tiles.
Support agents and CSMs, please refer to the Internal Memo to get latest refresh request forms.
See Also
- KBA 2835061 - SAP SuccessFactors Learning - Automated Refresh Process IRT
- KBA 2250223 - Edit or delete a report job scheduled by another admin
- Post Refresh Activities
Keywords
sf, successfactors, lms, learning, refresh, instance, snapshot, DB, database, dump, clone, process, LRN-61980, COSD-37358, Restore Recurring Jobs Status , KBA , LOD-SF-LMS-REF , LMS Manual Refresh , LOD-SF-LMS-SER , Config. Consulting & Service Requests , LOD-SF-LMS-IRT , Instance Refresh Tool , How To
Product
Attachments
| LMS_Instance_Refresh Request Form_V2_1.docx |
SAP Knowledge Base Article - Public